Auto detect 32-bit Linux OS, or have the option of a 32-bit Linux agent

The web site does not detect 32-bit Linux OS, or have the option of a 32-bit Linux agent.

Ubuntu 14.04.3 LTS

Linux Hulk 3.13.0-52-generic #86-Ubuntu SMP Mon May 4 04:32:15 UTC 2015 i686 athlon i686 GNU/Linux

$ file ArduinoCreateAgent-1.1-linux-x64-installer.run
ArduinoCreateAgent-1.1-linux-x64-installer.run: ELF 64-bit LSB executable, x86-64, version 1(GNU/Linux), statically linked, stripped

Chrome Version 42.0.2311.135

Hi!

We aren't supporting linux-2 yet for a couple of reason:

  • it's not widely used anymore
  • it requires a linux32 machine with some libraries installed.

Maybe in the future we'll find an easy way to support it, but right now I'm afraid you'll have to compile it yourself.

It's not difficult, you can follow the instructions here: GitHub - arduino/arduino-create-agent: The Arduino Create Agent