.../avr/bin/ar.exe: unable to rename 'core\core.a'; reason: File exists

My Arduino IDE worked flawlessly on my HP laptop (Windows10 64bit) until I decided to move the sketchbook folder from C: to D: (laptop has 2 HD's). Now I get this message:

c:\users\John\appdata\local\arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2\bin../lib/gcc/avr/4.9.2/../../../../avr/bin/ar.exe: unable to rename 'core\core.a'; reason: File exists

Tried: 1. Resetting sketchbook location. 2. Uninstalling and re-installing IDE (rebooted Laptop inbetween). 3. Running arduino.exe as Administrator. No change. I'm pretty sure there are some leftovers in the system that somehow don't get erased by uninstalling and make the problem reappear.

Any help will be greatly appreciated.

John

Update to my previous post.

SOLVED!

McAfee AV was causing the problem. I had a limited time trial version that came with my new HP laptop. Removed it properly via Windows10 control panel (Apps option) without any problem and Arduino IDE is back to its old good self.

John