AVR Dude Error

Hia Guys, I have a Freeduino 1.22 w/ the ATMega328, when I try ton upload a program I get an AVR dude error, coan you help?

The error is:

Binary sketch size: 976 bytes (of a 30720 byte maximum)


avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Thanks, /me

Did you select the right type of board in the boards menu ?

Hi,

This is my very first post. I had build my arduino board by hand (even the serial cable was build by hand) and after assembling everything when I try to upload the sketch on to my microprocessor, I get the same error message. I tried experimenting with different board setting but none were helpful. When I upload, the receiving light turns on but soon the error message follows. I am not sure whether the chip I am using has bootloader or not and I don't know anything about burning boot loading. As I said this is the very first time I have actually build something out of curiosity. So, help would be highly appreciated.

Error Message: "avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Make sure you select the Duemilanove w/ AT328 and not the Duemilanove/Duecimila w/ AT168. Click

Good luck!

I have the right Board and only COM port selected, I can receive Serial Data (nothing, but it is coming through) and still I get the AVR error, ios there something I am doing wrong in the upload, I only click the upload button on the PC, nothing else.

Regards /me

Did you already do the RX/TX pin loopback test ?

Take a wire and connect RESET to GND to disable the microcontroller.
Then take another wire and short pin-0 and pin-1.

Use the serial monitor and input some text. If you press SEND, it should be echoed back.
If that works, it may be a bootloader problem or a dead chip.

You can try changing the upload speed of the IDE for your board. It’s either 19200 or 57600.
Changes need to be made in boards.txt + restart of the software.

I'm having the exact same problem except with a new arduino mega. The loopback test works fine and ive tried changing the upload speed to both 19200 and 57600

I had the same problem after loading 0016. I unplugged the usb cable, reinstalled the FTDI drivers and plugged the usb back in. All works well now.

Doesnt seem like the drivers are the problem because my Diecimila works fine and it also happens on both my pc and mac.

It just keeps blinking 4 times holding the last blink a little longer.

I am having the same problem as chankster. I tried all of the things in the troubleshooting list on the arduion website, and none of them worked. I tried linux, windows xp (in virtualbox with usb port forwarded), and windows vista x64, and all gave the same error. (avrdude: stk500_getsync(): not in sync: resp=0x00, avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51). This is a brand new arduino mega. Just came in today from liquidware. The loopback works fine with the serial monitor. I have the correct port and board selected. When I try to send the blink program, the receive led blinks three times, but the transmit light never comes on. Any ideas?

Thanks, Brian

Interesting, because I also got mine from liquidware. Here's a video of what mine is doing

http://www.youtube.com/watch?v=xaTC_GWw-d8

Yeah. That looks like the same problem that I am having. Maybe it's a bad batch of boards or something?

Here's the response I got from the guys at liquidware

Hi Travis,

At first I didn't believe it, because I have my Mega here and I just programmed just fine!

So I told Mike about this and he suggested grabbing a Mega from the latest batch. He tried to program it, but got the same issue you described -it can't program!

There is definitively something different about the Megas produced 1 months ago versus the more recent batches.

I've copied Mike here because he is in regular touch with the Arduino guys in Italy. He's getting in touch them now and as soon as I hear more, I'll keep you posted.

Talk to you soon, Chris

Thanks for the response chankster. I just called them a second ago to let them know that I also received one of the boards.

I just bought 3 boards, Duemilinove and get the same error:

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

What's the deal????????

:(

same for me

have a diecimila and got the same thing
just got 0016
loop feedback does not work
i am just doing Blink
i got with verbose mode on:

Binary sketch size: 896 bytes (of a 14336 byte maximum)

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

Using Port : \.\COM4
Using Programmer : stk500v1
Overriding Baud Rate : 19200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51] [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done. Thank you.

:exclamation I Need Help! :exclamation

loop feedback does not work

are the FTDI drivers installed properly ? do you see an additional serial port when you plug it in ?

hey guys, i just saw this post come up about the mega... i don't really know what it might be, but the one i have at home works perfectly? i have a vista laptop that pretty much never worked (for some reason the driver crashes my computer every once in a while when it downloads, but that's with the diecimila and duemilanove too), so i always do programming on my xp desktop.

sadly i'm still at work :-( but i'm going to run home as soon as i can to see if i can help. in the meantime i just emailed chris too i think he's home, and maybe he can see what's up?

hmmmm....

matt

i have two Mega's that i dug out of my desk that seem to program correctly.

i'm using the Arduino 0016 version, which one are you using?