Avr I2c not supported for Nano Every

Because of memory limitations with the Nano, I bought a Nano Every. I connected it today and get one compiler error:

"#error Avr I2c not supported for this chip".

I assume this is wire.h, as the program worked with the Uno and Nano processors. The board is a genuine Arduino and selected board was Arduino Nano Every. Code uses: #include <wire.h> and wire.begin. I added wire.setClock(400000L) at the suggestion of one Forum article.

A review of previous Forum posts, GitHub, and the web did not suggest a library to use in its place.

Thanks

R

What version of the IDE are you using? You may have an outdated installation.

Please post the code you tried to compile, using code tags. Also post the complete error message.

Other people report success using the Wire library with the Every, for example: EVERY and I2C Wire library

1 Like

The Arduino I2C/Wire/TWI library is named "Wire", not "wire". Try #include <Wire.h> and see if the results are better.

John:

Thanks for your suggestion. It is “Wire.h” in my program … I just misspelled (typing from memory). I was really wondering if there was an updated version of Wire.h I should be using. A look through Library manager does not show any. By the way, the code worked as written on my Uno.

Lately I just seem to leap from problem to problem!. My second problem is getting my WeMOS d1 mini working again after a “failure in the build sequence” (or some such verbiage). Anyway I took your advice and (1) saved my libraries, (2) re-installed Arduino IDE 1.8.16, (3) installed my libraries, and (4) installed Python 3.10. Then I went to Files>preferences>additional boards and typed in https://arduino.esp8266.com/stable/package_esp8266_index.json and press “OK” (as instructed by the Arduino instruction on additional boards) to get the data on esp8266 boards. What I get “error: downloading https://arduino.esp8266 … etc.

I am now also missing the esp8266 library. So I went to Github and downloaded esp8266/Arduino (arduio-master.zip). When I used the “add zip file” option of library manager, I get the message: “folder/zip file does not contain a valid library … no header files found “

I get the impression that maybe the new download of the Arduino IDE is messed up in some way. I’ll start over with the re-build.

Maybe stamp collecting is the hobby for me.

Thanks for your suggestions,

R

Wire is a "platform bundled library". This means that it is installed as part of the boards platform ("Arduino megaAVR Boards" in the case of the Nano Every) you install via the Arduino IDE's Boards Manager tool. This is why you won't find Wire in Library Manager.

The platform bundled library approach is often used for libraries that are very hardware-specific, as is the case with Wire. Even though the high level API of the library is standardized, the low level implementation code might be very different from one board to another. Due to this standardization of the API, it might not be at all obvious that you are actually using a completely different Wire library depending on whether you are compiling for Nano Every, Wemos D1 Mini, Leonardo, etc.

Please post the full and exact text of the error message. Providing a fragment is not at all helpful.

The error message is correct. That is not a library. It is an Arduino boards platform. They are two completely different things.

Even though it is possible to manually install the ESP8266 boards platform (though by a different method from the one you tried), I very much recommend against it because it is very complicated. Let's try to troubleshoot your Boards Manager problem.

I don't think so.

Most likely your original error was caused by the sketch code. That would have been obvious if you hadn't only posted a fragment of the error.

As for your error installing ESP82666 boards platform via Boards Manager, that is very unlikely to be caused by a problem with the Arduino IDE installation.

I think: package_esp8266_index.json
should be: package_esp8266com_index.json

After you put that in right you should be able to go to Tools -> Board: -> Boards Manager... and search for esp8266

Thank you for your help. Don’t know how many times these old (78) eyes looked at that and didn’t see it. Anyway, I got my Nano Every working, with Ug82 graphics and SD card storage.

R