AVRDude - Arduino ISP issue.

Hi, I successfully set up an arduino uno as an ISP for some Attiny85 chips that I have, but this only seems to work through the arduino IDE (as in loading sketches through there.) Whenever I try and run avrdude on it's own, I always get this error:

stk500_getsync() not in sync: resp=0x00

Here's the parameters I'm feeding AVRDude:

avrdude.exe -p t85 -P com7 -c arduino -t -u

I've also tried setting the baud rate to 9600.

Any clues as to why this would happen? I'm wanting to move away from the arduino libraries soon so ideally I'd like to get avrdude working on it's own.

[edit] I've tried using the latest version of avrdude and the one supplied with the arduino IDE, same results.

I'm using my UNO with the adafruit ZIF programmer protoboard and while I have not tried to run the AVRdude separately, it is addressed here: (Note, Ladyada has her own sketch for the UNO and her board layout)

http://www.ladyada.net/library/arduino/arduinoisp.html

You can use ArduinoISP from the command line very easily, with AVRdude which is the standard program used to program AVRs by running:

avrdude -c arduino -p atmega328 -P COMPORT -b 19200 -U flash:w:filetoburn.hex

Instead of atmega328 you can also program atmega8 atmega88 atmega48 atmega168 etc

  • Ray

That was it! Can’t believe I missed that, I figured it was to do with the baud rate - setting it to 19200 worked. Thanks for the help!