avrdude error

Ok, I am new to the arduino as a whole. I am building a quadcopter and have uploaded numerous times to it. I just made a quick change and was using the aeroquad software to do some final tweaks. Went outside and could not get the unit to power on. Back to the computer and I noticed I do not have a green light, only a red power light. I tried to upload and I get the typical avrdude errors that I have seen by searching through the forums. On my xbee connector I only get a TX (red) but no RX (green) when I am trying to program with it.

I have unplugged, restarted and tried hitting the reset at various times to no avail. When holding the device it feels like the atmega is getting very hot, this did not seem normal as before. Here are my particulars:

Arduino Pro Mini with ATmega 328 AeroQuad mini kit 1.0 Windows 7 64bit Arduino 0022 to program

When I get a verbose upload here is my output:

Binary sketch size: 26458 bytes (of a 30720 byte maximum) G:\arduino-0022\hardware/tools/avr/bin/avrdude -CG:\arduino-0022\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\.\COM5 -b57600 -D -Uflash:w:C:\Users\alex\AppData\Local\Temp\build3529833995564198071.tmp\AeroQuad.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

System wide configuration file is "G:\arduino-0022\hardware/tools/avr/etc/avrdude.conf"

Using Port : \.\COM5 Using Programmer : stk500v1 Overriding Baud Rate : 57600 avrdude: ser_open(): setting dtr avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Recv: avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: Send: Q [51] [20] avrdude: Recv: avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done. Thank you.

Everything was working great and then it all just died. I also read many posts on the forums before posting but nothing that I tried worked or was quite the same as my situation (that I could find). Any help is greatly appreciated and please remember that I am somewhat of a noob when it comes to this device. Thanks in advance for any help...


Perform a "loop-back test"...

• Disconnect power from the board

• Remove all connections and shields from the board

• Force the processor to remain in reset by connecting a jumper from RESET to GND

• Connect a jumper from pin 0 to pin 1

• Connect the board to your computer

• Start your favourite terminal application (Serial Monitor will work)

• Connect the terminal application to the serial port for your board. The baud rate is irrelevant.

• Send data by typing. Everything you type should be echoed back.

• Shutdown the terminal application

• Disconnect the board from the computer

• Remove the two jumpers

Does that work?

I had a feeling someone was going to respond back with this response :( I guess I need to un-solder the board now so this is going to take a few days to do the testing. If the ATmega chip is getting very hot, is that an indication of a short or fried chip? Well, guess I need to work on finding a solder sucker now...


If the ATmega chip is getting very hot, is that an indication of a short or fried chip?


Well it took me way to long to finally be able to remove the arduino from the shield and I think I finally killed it in doing so. I have ordered a new shield and arduino since I can't even get a red light anymore. Thanks for all the help and hope the next one goes better :)