avrdude Fehlermedung, failed to write flash memory

Hallo,

ich erhalte folgende Fehlermeldung bei dem Versuch eine Sketch auf einen Arduino mini zu übertragen.

avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x64 avrdude: failed to write flash memory, rc=-4 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Hat da vielleicht jemand eine Idee?

Danke im voraus

Sebastian

Noch eine weitere Info:

Das bereits werksseitig aufgespielte Beispielprogramm Blink wird ausgeführt.

Also, das wirkt so, als hättest Du das falsche Board ausgewählt. Kann das sein? Guck in der IDE mal welches Board du ausgewählt hast.

Kleiner Test, wenn es das richtige Board sein sollte..... Arduino vom Strom ab, dann wieder dran, und gggaaaaanz schnell neues Sketch hochladen... das braucht vielleicht ein paar versuche....

Sagmal ist das ein originaler Arduino?

Lieber Gruß ChrisS

Hallo ChrisS

Frage etwas weiter weg vom Thema:

Kleiner Test, wenn es das richtige Board sein sollte..... Arduino vom Strom ab, dann wieder dran, und gggaaaaanz schnell neues Sketch hochladen... das braucht vielleicht ein paar versuche....

Ist das nicht das selbe wie ein Reset oder lange gedrückten Reset?

Grüße Uwe

Hi Chris,

ich hab den mini(nicht das Original, sondern aus China mitgebracht) ausgewählt. Daran sollte es nicht liegen.

@ Uwe, ich würd sagen, das es das selbe ist...

Sebastian

PS: Chris, irgendwoher kenne ich Das Bild von Dir! DIY Drone, MikroKopter, Freeduino,....

So, ein Teilerfolg. Der mini scheint nicht in Ordnung zu sein. Die ganze Geschichte dort: http://arduino.cc/forum/index.php/topic,50833

Vielleicht ein großes Onlinespiel ? :) Oder eines der großen Social Networks....

Mich kann man überall her kennen, Norddeutschland ist aber verdächtig.... Komme aus dem Raum Celle/Hannover und bin nun in Dresden...

Schön daß es jetzt klappt....

Lieber Gruß ChrisS

Hi,

leider klappt es ja noch nicht. Aber zumindest ist klar, dass der mini schuld ist. Ich hoffe ich bekomme ihn noch zu einer Mitarbeit bewegt...

Sebastian

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1292974517

Hast Du das schon gesehen?

Solltest wirklich mal den Bootloader austauschen....

Lieber Gruß ChrisS

Das ist leider nicht mein Fehler, er bekommt ein "not in sync", was ich erhalte wenn ich den Reset nicht richtig ausführe. Ich hab aber ein "failed to write flash memory"...

mmh, wohl wahr, aber ich könnte mir vorstellen das ein falscher Bootloader ebenfalls zu nicht flashbarem Speicherführt, weil er falsch adressiert.

Da es noch keine weiteren Ideen gibt, und es in der Ferne anscheinend passiert Garkeinen oder den falschen Bootloader drauf zu haben,
wäre es sicher einen Versuch wert.

Lieber Gruß
ChrisS

Jupiiiii, mit dem neu aufgespieltem Bootloader funktioniert der kleine! :slight_smile:

Na dann, habe ich ja doch ein gutes Tageswerk getan… :wink:
Dachte schon die Pfadfinder schmeißen mich raus :wink:

Schön, freut mich daß es geholfen hat.

Lieber Gruß
ChrisS