AVRdude: How to find port number for AvrIsp MkII in linux?

I am trying to use avrdude from the command line to determine the fuse settings I used on a previously programmed chip.

The command line requires a “-P” parameter for the port that the AvrIsp programmer is on. This port does not show up in the Arduino IDE like a FTDI chip would, and therefore I can’t get the USB port descriptor for Avrdude.

Does anyone know how to get this port number on an Ubuntu PC?

It's -Pusb

Thanks Pert but no cigar...

"sudo: Pusb: command not found"

Doh...

Sorry about that. Thought it was a command but I will try the parameter "-Pusb"
Cheers

Tried the "-Pusb" but got "avrdude: ser_open(): can't open device "usb": No such file or directory"

Also tried "-P usb" but got the same.

Try this:
Connect your AVRISP mkII to your computer, but not to any Arduino board or chip.

  • In the Arduino IDE, select File > Preferences > Show verbose output during upload (check)
  • Tools > Programmer > AVRISP mkII
  • Tools > Burn Bootloader

Do you get the same "avrdude: ser_open(): can't open device "usb": No such file or directory" error? The process is expected to fail since the programmer is not attached to a target, but you should get an error like this:

avrdude: stk500v2_program_enable(): bad AVRISPmkII connection status: Target not detected

Thanks Pert. My PC was a bit flakey so I re-installed with the latest Ubuntu and all is well.
Your parameter "-P usb" works fine now. For others edification, when leaving the -P parameter out altogether, avrdude defaults to usb and therefore it worked with or without the -P parameter. However I prefer to use the parameter to be sure where the program is looking.