avrdude not in sync error with new Arduino IDE, but works with 1.6.4

Hi,

I am using multiple different Arduino Nanos and recently have run into issues with uploading my code. I updated to the newest version of Arduino and that didn’t work. The error code I am getting from Arduino 1.8.5 is shown below. The IDE works fine for uploading to an Arduino Uno.

For the Nanos that are not uploading properly, if I switch to Arduino 1.6.4 the upload goes fine. I’ve also posted the verbose output for that below.

One thing I notice that is different, is the “Overriding Baud Rate” for the 1.6.4 upload is 57600, whereas for the 1.8.5 upload it is 115200.
Does this have anything to do with it?

Thanks,
Blake

1.8.5:
System wide configuration file is “C:\Users\Blake\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino9/etc/avrdude.conf”

Using Port : COM7
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x83
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x83
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x83
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x83
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x83
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x83
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x83
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x83
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x83
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x83

avrdude done. Thank you.

1.6.4:
System wide configuration file is “C:\Program Files (x86)\arduino-1.6.4\hardware\tools\avr/etc/avrdude.conf”

Using Port : COM7
Using Programmer : arduino
Overriding Baud Rate : 57600
AVR Part : ATmega328P
Chip Erase delay : 9000 us
PAGEL : PD7
BS2 : PC2
RESET disposition : dedicated
RETRY pulse : SCK
serial program mode : yes
parallel program mode : yes
Timeout : 200
StabDelay : 100
CmdexeDelay : 25
SyncLoops : 32
ByteDelay : 0
PollIndex : 3
PollValue : 0x53
Memory Detail :

Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


eeprom 65 20 4 0 no 1024 4 0 3600 3600 0xff 0xff
flash 65 6 128 0 yes 32768 128 256 4500 4500 0xff 0xff
lfuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
hfuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
efuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
lock 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00
signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : Arduino
Description : Arduino
Hardware Version: 2
Firmware Version: 1.16
Vtarget : 0.0 V
Varef : 0.0 V
Oscillator : Off
SCK period : 0.1 us

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude: Device signature = 0x1e950f
avrdude: reading input file “C:\Users\Blake\AppData\Local\Temp\build739471601181305352.tmp/hallsensor.cpp.hex”
avrdude: writing flash (4558 bytes):

Writing | ################################################## | 100% 1.28s

avrdude: 4558 bytes of flash written
avrdude: verifying flash memory against C:\Users\Blake\AppData\Local\Temp\build739471601181305352.tmp/hallsensor.cpp.hex:

In the "Tools" menu, set the Processor to "ATmega328 (Old Bootloader)"

That worked. Thank you.

...I feel terrible about spending hours looking for that solution