avrdude problem on Linux 64bit problem

I downloaded the 64bit version of the Arduino software for Linux and I wasn’t able to upload the code to the Arduino Uno board.

The error given by the IDE was:
java.io.IOException: Cannot run program “<install_path>/arduino-0021/hardware/tools/avrdude”: java.io.IOException: error=2, No such file or directory

I checked and the avrdude file mentioned in the Java exception exists and has the right permissions (a+rx). However, it seems like it’s compiled for a 32bit OS as vs. to 64bit:

arduino-0021$ file hardware/tools/avrdude
hardware/tools/avrdude: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.0, not stripped

The stock version on my OS (Debian testing) is compiled for 64bit and seems to work fine (I was able to upload firmware to the flash using the command line):
arduino-0021$ file /usr/bin/avrdude
/usr/bin/avrdude: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, stripped


Have you tried renaming the 32-bit one to something else, then making a symbolic link to the one in /usr/bin? Try that.

I already tried that and it does go a bit further. However I get this error instead:

avrdude: Yikes! Invalid device signature. Double check connections and try again, or use -F to override this check.

According to one of the troubleshooting topics Arduino uses a customized version of avrdude. http://www.arduino.cc/en/Guide/Troubleshooting#toc23

I could try to pass -F flag to avrdude but the command line is probably somewhere in the Java code.

My only other suggestion would be to pull the avrdude from an older Arduino install for 64-bit, and try that. If that doesn't work, I could try to send you a copy of my avrdude (I only have 0019 setup, currently, though)...

I grabbed the avrdude and avrdude.conf files from the 64 bit version of the 0018 release and that fixed the problem. I'm able upload the firmware w/o issues.

In any case, the official release of the software should be fixed as well. Is there a way I can file a bug report to get that done?

I think you can try here: https://launchpad.net/arduino

Try here - I don't know what that is above...


The bug list is here: http://code.google.com/p/arduino/issues/list