avrdude: ser_open(): can't open device "\\.\COM3": Access is denied.

potatomagnet1: I'm also having this problem but i can't find the device manager anywhere.

Please use your own thread, http://forum.arduino.cc/index.php?topic=384997.0

@terry777 thank you! Your solution worked for me. It was a COM port # conflict. Changing the COM number did the trick!

In my case, none of this worked. Turns out the problem was that Windows Update for Win10 "updated" my USB host controller and the new driver malfunctioned, but only in a few specific cases, the use of an Arduino Uno being one of them. The fix was to uninstall the driver and reinstall the manufacturer-supplied driver. Just one more thing to look at in the event you have this issue.


I had the same problem with the UNO. I went to control panel->devices and printers. I right click on the Uno and seen that its showing incompatibility with USB 3.0. Even tho i know i have 1 usb2.0 port and 1 usb3.0 port, it showed the same issue for both ports. I went to my BIOS setting on my laptop and disabled USB3.0. I restarted my computer and it all worked out :)

in my case hepls: use another cable....

I hade the same issue. It was because RX and TX pins were plugged in to a wifi-module. Not sure why it's happening, but disconnecting the pins made it work again.

This is my first day with the Arduino. Mine is a Kuman Uno, Christmas present 2017 :)

The COM port number was different but I had the same issues as most others on here. I followed all the suggestions on the first page but it still came up with errors. In the end I changed the Baud rate to 57600 and it worked.

It occasionally loses the plot but restarting the Arduino IDE software and unplugging and reconnecting the UNO seems to get it going again.

I'm really enjoying it. It's been over 45 years since I did any real electronics, and I've haven't really done any programming before.

Only casualty so far is an LED. I got creative and didn't put the resistor in the circuit correctly. But Hey Ho, you can't make an omelette without breaking a few eggs :)

Hope this helps someone

I tried to connect arduino uno after using arduino mega, changing the cable to the one I used with arduino mega solved the situation.

rupertschierz: in my case hepls: use another cable....

This was my case too

Hi everyone i have the same problem with same message i tried changing the com to another and it worked for a few projects now i get the same message and i cant seem to find out what the problem is.

The usual culprit is a mobile phone / PDA application running in the background that constantly probes for a connected device.

Not sure if this will help anyone else, but with the 3d printer kit I purchased it had me install the Repetier Software which has a server and host component. The server was constantly connecting to the arduino and preventing me from being able to upload.

I was able to

  • End Process in task manager for avrdude.exe
  • Disable the com port to the arduino in device manager (triple low beep)
  • Enable com port to the arduino in device manager (low/high beep). Upload was successful and stable.

As always, verify Arduino IDE|Tools|Board: and Port: are correctly selected (my board changed once, port becomes deselected occasionally)

If you go to C:\Program Files (x86)\Arduino\hardware\tools\avr\bin and can't delete avrdude.exe then it is probably still running and the process needs to be ended - I learned this by trying to delete the Arduino folder (to reinstall) but was unsuccessful because this program was still running.

This has been massively frustrating - Upon Sketch|Upload the avrdude.exe program should be killed automatically.

Thank You, it solved my problem. Arduino Mega 2560

terry777: solution!!!! 1. device manager 2. select ports 3. select port of arduino board examle : com1 ... com3 whatever it is 4. right click on com. 5. select properties 6. tab- port settings 7. click advanced 8. com port number- select new port number that is not in use. 9. confirm.. save and continue

the problem is a conflict between hardware devices, ie. the port is now used by another hardware device, mouse, ect..

Same problem here. I just needed to disconnect the RX and TX on D0 and D1 and it works. I just wanted to provide my feedback on this. I was looking for this too.

I'm having a similar problem I'm trying to upload to, what I believe is a Chinese fake UNO R3. Under tools the port option is visible but unavailable and I'm getting ( avrdude: ser_open(): can't open device "\.\COM3": The system cannot find the file specified. ) for an error message. any advice would be great.

Actually agcsoft's link to the Chinese drivers was exactly what I needed Thanks a ton.

I encountered this error and something close to the error as in the following URL: https://forum.arduino.cc/index.php?topic=28223.30 While my Uno was connected to pins tx and rx and while connected I tried to upload a sketch.

The assumed reason for it is the fact that these pins are able to load a bootloader to the Arduino and if they are connected, the board expects to be loaded with a bootloader.

I've just had this same issue. Tried lots of the solutions above but the fix for me was unplugging a MTB GPS device that was on connected to my PC via USB. As soon as I unplugged that device everything worked fine.

avrdude: ser_open(): can't open device "\.\COM3": Access is denied.

I tried all the solutions but none of them worked