avrdude: ser_open(): can't open device "/dev/ttyUSB0": Permission denied

what am I doing wrong here please help!!

unable to upload any sketches.

Am using
Linux
IDE 1.8.5

with a Nano

have full access to the /dev/ttyUSB0

dxw11@M73:~$ ls -l /dev/ttyUSB0
crwxrwxrwx 1 root dialout 188, 0 Dec 27 11:04 /dev/ttyUSB0

Am a member of the group
dxw11@M73:~$ id -Gn
dxw11 adm tty dialout cdrom sudo dip plugdev lpadmin sambashare

avrdude: Version 6.3, compiled on Jan 17 2017 at 11:00:16
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "/snap/arduino-mhall119/5/hardware/tools/avr/etc/avrdude.conf"
User configuration file is "/home/dxw11/snap/arduino-mhall119/5/.avrduderc"
User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/ttyUSB0
Using Programmer : arduino
Overriding Baud Rate : 57600
avrdude: ser_open(): can't open device "/dev/ttyUSB0": Permission denied

avrdude done. Thank you.

You're using the unofficial Snap package of the Arduino IDE, which has previously been reported to cause this problem. Please uninstall that thing and then install the official Arduino IDE, downloaded from:

I have downloaded and installed and reinstalled the IDE(version 1.8.8) many times and also installed version 1.8.5 on advise to fix this issue. Software was directly loaded from this site.

wander44:
Software was directly loaded from this site.

The output you posted clearly shows that's not true:

wander44:
System wide configuration file is "**/snap/arduino-mhall119/5/**hardware/tools/avr/etc/avrdude.conf"

yes your right my error
I have 2 machine loaded up that I am attempting to get this working on .
I do post the wrong one

avrdude: Version 6.3-20171130
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "/home/dxw11/ide/arduino-1.8.8/hardware/tools/avr/etc/avrdude.conf"
User configuration file is "/home/dxw11/.avrduderc"
User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/ttyUSB0
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00

the issue is with Processor selection have switched to AT328P (old bootloader) now i can get this to work!