avrdude : ser_open (): Cant open device

Hello! I recently bough a genuine Arduino Nano and have finally gotten around to loading it with some code, unfortunately im getting the seemingly common avrdude : ser_open (): cant open device error message. I have looked at this topic on older forum posts and they dont seem to help much for me. I have restarted my PC, reinstalled the IDE, and replugged in the nano, none of it seems to help. Im thinking it is a driver issue as my sunfounder uno works just fine. If this is my issue, where can i find these drivers? Thanks!

Which NANO exactly as there are new variants that require additional board support to be installed ? See lower in the sections for those types of NANO.

Could you also take a few moments to Learn How To Use The Forum.

Other general help and troubleshooting advice can be found here. It will help you get the best out of the forum in the future.

What does your operating system (which one) think of your board; is it properly recognised as a serial device?
In the IDE (which version), did you select the correct serial port?

I can’t select a port, it is greyed out. I’m on windows 10, and my IDE is 1.8.3. When it’s plugged in device manager it shows up just not as an arduino and asks to install drivers as it doesn’t work with it.
My nano is a A000005

asks to install drivers as it doesn’t work with it.

Please rephrase that.

See further “common issues” in ballscrewbob’s second link.

Okay im finally home to work on this, in device manager when I look it up, it appears as FT232R USB UART, with a little warning icon. And when i go into its properties it states:

The drivers for this device are not installed. (code 28) There are no compatible drivers for this device. To find a driver, click update driver

Using this info i went to the FDTI Site and downloaded drivers for the FT232R and installed them in the FT232R error thing and it still doesn't work, even after restarting my PC, so I am quite lost. Also the L light on my board is blinking, not sure what it means but might as well include it.

update, I installed the MegaAVR Library in the IDE And switched to it as it has every nano listed, yet even with it and a restart, its still giving me the same error.

L light won't blink if there is no code loaded to make it blink (either in the bootloader, or in sketch).

Not sure why you are having trouble with the FT232 driver. You installed 2.12.28 from here? https://www.ftdichip.com/Drivers/VCP.htm

Yup that'd be the page I got it off of. I'm not real sure either, maybe if I reset the board it'll load?

When they installed it recognized the Nano as a USB Serial device or something like that. Sorry for being vague, not at home again

Don't be vague; rather wait till you can provide complete information.

To my knowledge, a Nano will always been seen as a serial device and not as an Arduino Nano.

Okay gotcha, I’ll try to reinstall them when I get home and report back with hopefully good news

update: installing again worked! Thank you for the help!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.