avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

AdiDaBoss: Sorry I have not kept up to date with this topic, but isn't this fixed by the link 'How to fix bad Chinese clones' in an earlier post of mine? [Dec 01, 2018, 04:56 am]

I encounter exactly this problem, solution in my case was: select "OLD Bootloader" in the IDE.

I had the same issue and I resolved it as 'Callmebob', so as Bob suggested..

"I solved my problem by messing around with choosing different boards from the menu choices (Tools > Board > ATmega328P -- and Tools > Board > ATmega328P (Old Bootloader), and a few other menu options, and opening and closing different sketches and magically it started working again with ATmega328 menu choice."

Hi all!

I just registered to be able to post my solution to this problem, hoping it will help anybody out there.

In my case there was some solder between the first and the second pin of the IC on the FTDI board, making Rx and Tx not work. After removing the solder with a soldering iron everything runs fine now and I'm very happy.

There is a little FTDI board test tutorial at AdaWiki with a link to a small test program. This helped me a lot.

Thank you all for your time and efford discussing this problem as I learned a lot about arduino and ATmega328P from it.

Keep it up!

Best regards, xbio

I had this issue, tried various things but same problem,after checking my board saw it had a Atmega 128 chip, changed in ide, tools, processor from Atmega 328 to atmega 128 and it uploaded ok

ALL THIS CANT BE READ BE AN EUROPEAN , TOO MANY WORLD TO TRASLATE... IS THAT SO DIFFICULT WRITE THE ANSWER TO THE QUESTION? NO ONE METTERS THE CHAT!!

cod: ALL THIS CANT BE READ BE AN EUROPEAN

This it the section of the forum for English language. If you don't like that, then you're welcome to use the forum board for your language of choice: https://forum.arduino.cc/index.php#c6

cod: TOO MANY WORLD TO TRASLATE.

There's this really useful thing called Google Translate: https://translate.google.com/ If you use Google Chrome, it's built right into the browser.

Entorno:
Ubuntu 20.04
Arduino Nano Chino con el
Future Technology Devices International, Ltd FT232 Serial (UART) IC

lo solucioné con lo que muestra el siguiente video:

Resumiendo, simplemente seleccioné en Herramientas-Programador-Atmega328p (Old Bootloader)

No compro más cosas chinas, perdí dos horas buscando la solución!

Saludos

Can anyone help me ?
when I try to upload code on my clone arduino nano then this comes as an error

  • avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x38
  • avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xad
  • avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xa8
  • avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x0f
  • avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x9d
  • avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xad
  • avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x98
  • avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xe8
  • avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xd6
  • avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xd6

Have you tried the old bootloader option under tools -> processor in the IDE?

Did you read all the replies in this topic? The above possible solution was mentioned before.

Yes I read all the solutions mentioned above and tried those solutions which are possible for me right this time but still it was not working though this is my 2nd time when I m facing this error... previously I installed the lastest version of IDE and it worked for me...but this time installing the lastest version doesn't help me... I uploaded several programs using

Correct port
Correct Arduino board (Arduino nano)
Old bootloader
Correct Programmer (avrsip mkll)

How do you solve for Arduino Uno? I have gone to the web and the app version, different computers (Chromebook and Mac) and the error suddenly happened. It couldn't upload any code. Changing the code and the wiring shouldn't affect it.

All Arduino Uno boards have the same bootloader, so it's impossible for the error to be caused on the Uno by having the wrong bootloader option selected. That information is exclusive to the Arduino Nano.

Not the code, but the wiring definitely can affect uploads. Pins 0 and 1 on the Uno are also used for uploads, so connecting anything to those pins can cause the upload to fail. The reset pin is also used for uploading. Incorrect wiring can also cause permanent physical damage the board, which can cause uploading to fail.

1 Like

Thank you for the information. :slightly_smiling_face: I wired it wrong and put wires into pins 0 and 1. I have realized this and switched to pins 2 and 3 and changed the code for the pins, and it worked. Four hours later, nothing was working. I don't think that the power supply is at fault.
I was using the prototyping shield on top of the Uno during the time. Is it the prototyping shield that is damaged or the Arduino board? I put power into the Arduino board this morning, and the "ON" light and the orange light on the board still turned on. I have also connected an LED to the board, and it glowed. I think it is the prototyping board that is damaged. This morning, I tried connecting the Arduino board with the prototyping shield to the computer, and the port I was using didn't even show up in the options, even after I cleared the cache.

I have connected an LED to the Uno board and it lit up. I connected it to the prototyping shield with board and it just flickered. I connected it to the Uno again and it lit up. That probably means that the prototyping shield is damaged, not the Uno.

DUDE! I was 3h searching why my clone board will not upload anything......

Thanks alot! I also have the crappy Mega 168 and not the Mega 328....

i got Message:
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xb5

I have successfully uploaded many sketches, using IDE 1.8.13, to various nano projects using the old bootloader. I'm using WIN10 which may have been updated since I last used Arduino IDE. I'm not aware of changing anything within the IDE. I'm getting 'avrdude: stk500_recv(): programmer is not responding' errors when attempting to upload a sketch. I've tried using different sketches, nano boards and cables with the same result. Going through the various suggestions posted here hasn't resolved the problem.

The device manager doesn't show an Arduino but two ports
'Communications Port (COM5)' and 'Intel(R) Active Management Technology - SOL (COM3)'

In the IDE 'tools - ports' menu I see COM3 and COM5 and tried both unsuccessfully.

I'm obviously making a simple mistake but cannot see what it is!