avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x31

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x31

HOw to solve it or what s the problem

Which Arduino board are you using?

make sure you don't have wires in pins 1 and 0, these are used for communication.

aljazcernigoj:
How to solve it or what s the problem

Beginning with a search over that most asked topic here?
SCNR...

its for 3d printer cr 10s it just doesnt load on it

Please do this:

  • (In the Arduino IDE) File > Preferences
  • Uncheck the checkbox next to “Show verbose output during: compilation”
  • Check the checkbox next to "Show verbose output during: upload
  • Click “OK”
  • Sketch > Upload
  • After the upload fails, you’ll see a button on the right side of the orange bar “Copy error messages” (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button.
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • Press “Ctrl + V”. This will paste the upload output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

Arduino: 1.8.9 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

Sketch uses 143428 bytes (56%) of program storage space. Maximum is 253952 bytes.
Global variables use 6239 bytes (76%) of dynamic memory, leaving 1953 bytes for local variables. Maximum is 8192 bytes.
Low memory available, stability problems may occur.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega2560 -cwiring -PCOM4 -b115200 -D -Uflash:w:C:\Users\Primoz\AppData\Local\Temp\arduino_build_212871/Marlin.ino.hex:i

avrdude: Version 6.3-20171130
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM4
Using Programmer : wiring
Overriding Baud Rate : 115200
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

avrdude done. Thank you.

An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Make sure you have selected the port of your Arduino board from the Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don’t know which port is your Arduino, you can find it like this:

  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.

I did this its port4

Arduino: 1.8.9 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

In file included from sketch\fastio_1281.h:34:0,

from sketch\fastio.h:54,

from sketch\fastio_AT90USB.h:35,

from sketch\fastio.h:52,

from sketch\fastio_1280.h:34,

from sketch\fastio.h:50,

from sketch\fastio_168.h:34,

from sketch\fastio.h:46,

from sketch\MarlinConfig.h:26,

from C:\PTC\Aljaž\Nova mapa (3)\Nova mapa\CR-10S E3Dv6 Marlin-1.1.8\Marlin\Marlin.ino:31:

fastio.h:320:2: error: #endif without #if

#endif // _FASTIO_ARDUINO_H

^

In file included from sketch\fastio_AT90USB.h:35:0,

from sketch\fastio.h:52,

from sketch\fastio_1280.h:34,

from sketch\fastio.h:50,

from sketch\fastio_168.h:34,

from sketch\fastio.h:46,

from sketch\MarlinConfig.h:26,

from C:\PTC\Aljaž\Nova mapa (3)\Nova mapa\CR-10S E3Dv6 Marlin-1.1.8\Marlin\Marlin.ino:31:

fastio.h:320:2: error: #endif without #if

#endif // _FASTIO_ARDUINO_H

^

In file included from sketch\fastio_1280.h:34:0,

from sketch\fastio.h:50,

from sketch\fastio_168.h:34,

from sketch\fastio.h:46,

from sketch\MarlinConfig.h:26,

from C:\PTC\Aljaž\Nova mapa (3)\Nova mapa\CR-10S E3Dv6 Marlin-1.1.8\Marlin\Marlin.ino:31:

fastio.h:320:2: error: #endif without #if

#endif // _FASTIO_ARDUINO_H

^

In file included from sketch\fastio_168.h:34:0,

from sketch\fastio.h:46,

from sketch\MarlinConfig.h:26,

from C:\PTC\Aljaž\Nova mapa (3)\Nova mapa\CR-10S E3Dv6 Marlin-1.1.8\Marlin\Marlin.ino:31:

fastio.h:320:2: error: #endif without #if

#endif // _FASTIO_ARDUINO_H

^

In file included from sketch\fastio_644.h:34:0,

from sketch\fastio.h:48,

from sketch\MarlinConfig.h:26,

from C:\PTC\Aljaž\Nova mapa (3)\Nova mapa\CR-10S E3Dv6 Marlin-1.1.8\Marlin\Marlin.ino:31:

fastio.h:320:2: error: #endif without #if

#endif // _FASTIO_ARDUINO_H

^

In file included from sketch\MarlinConfig.h:26:0,

from C:\PTC\Aljaž\Nova mapa (3)\Nova mapa\CR-10S E3Dv6 Marlin-1.1.8\Marlin\Marlin.ino:31:

fastio.h:320:2: error: #endif without #if

#endif // _FASTIO_ARDUINO_H

^

exit status 1
#endif without #if

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

what about that?

It looks like you messed something up when you were setting up the configuration of Marlin.