avrdude: stk500_getsync() error message

Hi all,

So I keep getting the avrdude: stk500_getsync() error message. After I click on upload I get back:

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00. This repeats with attempts 2-10, and a different resp = something. I know this is supposed to indicate the board/com port is not selected correctly. I checked boh of those. I also updated my drivers to the latest version. The only other thing it could be is that I am using analog pin 0 in order to measure a joystick position (there is a joystick and boad mounted ontop of the Arduino Uno). However, I have seen public code which calls for reading analog pin 0 so I am not sure if this is the error. Plus, even public code like Button from the Arduio site which doesn't use analog pin 0 won't upload.

Any tips as to what the issue might be / how to solve it? Thanks

I am using analog pin 0 in order to measure a joystick position

have you tried uploading while there is nothing connected?

I have tried uploading the code without the joystick control attatched ( it is on a separate board which aligns with the Arduino Uno.

The error message just indicates that the Arduino isn't communicating with the PC. When the board is plugged in, check the device manager to see what COM port it's on. Make sure that the correct port is listed in the IDE. I have seen instances of windows dropping a port.

If it's not listed in the device manager (you can check this by plugging and unplugging the board while looking in device manager), it's likely a driver problem. Usually this is cured by restarting the computer while the Arduino is unplugged. Then checking the device manager again.