avrdude: stk500_getsync() error - TTGO T5 ESP32 - No communication with board

Hi! I bought a esp 32 TTGO T5 v1.2 with ePaper display.

(This one, if what I wrote isnt clear enough https://de.aliexpress.com/item/TTGO-T5-v1-2-wifi-bluetooth-grundlage-ESP-32-esp32-1-54-2-13-2-9/32843165848.html)

Im using Windows 10 and the newest version of Arduino IDE (as ive downloaded it just a few hours ago).

I do not manage to communicate with the board over the Arduino IDE.

When plugging in the USB cable, the automatic demo of the display starts. Therefore, the hardware and software should be all good.

In tools -> Board I am unsure what board has to be selected. I think this is where the problem lies.

I have made some research and found out that there is 3rd party software that can be installed in the "hardware" directory of Arduino. Then, the board I need should show up in "tools -> boards". However, I do not know where to find this 3rd party software for the TTGO T5 product I bought. Some code specific to my board can be found on: https://github.com/LilyGO/TTGO-T5-ePaper1.54 ...But I do not know what part of this I should insert into the hardware folder (if any?)

Board Info: BN: Unknown board VID: 10C4 PID: EA60 SN: Upload any sketch to obtain it

When I try to upload something to the board, I get this error message.

Sketch uses 444 bytes (1%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes [... some time passes]
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x5f
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x77
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x61
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x6b
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x65
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x55
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x70
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x20
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x50
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x6f
An error occurred while uploading the sketch

Thanks for your help in advance! :)

I have the same problem. My mega was acting a little weird with this one code and I got the same error as you did, so I uploaded a different code and now it works great!