avrdude: stk500_getsync(): not in sync: resp=0x00 Error

Hello all,

I am not able to upload the firmware to my Azteeg X1... This is the second X1 with the same issue.

Error: Binary sketch size: 86214 bytes (of a 131072 byte maximum) avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Axteeg X1 w/ atmega 1284p 16MHz Marlin 1.03 Ardino 0023 Serial port 5

I did find this but dont really follow it or know how to apply it to the X1 Problem with auto reset

Arduinos with auto reset capabilities(i.e. Diecimila, Duemilanove) will likely need to have the auto-reset functionality disabled. When a program(i.e. avrdude) connects to a serial port the DTR line is set and unset, which triggers a reset. Avrdude (as of v5.6) connects to the Arduino before it has booted. The problem may manifest itself with the error message "avrdude: stk500_getsync(): not in sync: resp=0x15". The problem may also manifest itself withe the error message "avrdude: verification error, first mismatch at byte 0x0000 0x3F != 0x00". This happens when Avrdude connects to the Arduino bootloader on the host. The Arduino bootloader supports a subset of the same STK500 protocol that Mega ISP uses but always returns 0x00 when reading the lock bits

Tried 3 different USB cables, and rebooted my PC a few times.

You might have selected the wrong board, under tools > board.

I deleted Arduino0023, downloaded it again and everything now works fine.... not sure what happened but wanted to report what fixed it..