avrdude: stk500_getsync(): not in sync: resp=0x00

I am getting an error when trying to upload to my Arduino Uno R3. . avrdude: stk500_getsync(): not in sync: resp=0x00 . . I have the correct serial port and board selected. I have the arduino software loaded on both of my computers, it works perfectly fine with one but not the other. I have removed the software and installed it numerouse times and can not get this thing to work. Anyone have any ideas?

  1. Did you do the loopback test yet?
  2. Where did you buy the board from?

I'm having the same problem.
Could you explain the "loop back test"?
I bought it from DX

flaviocantinho:
Could you explain the "loop back test"?

It's the 2nd link on this forum. It is strangely named "Loop Back Test Instructions."

flaviocantinho:
I bought it from DX

Then it is a cheap clone. Most of them don't bother to program the bootloaders. You might also try changing the board type to Duemilanove since some of them are too lazy to use the latest bootloader.

He said it works fine on one PC but not another. So how in heaven is that going to be a bootloader related problem?

I suspect the OP needs to reload the USB driver on the PC that isn't working with the board.

Lefty

retrolefty:
He said it works fine on one PC but not another.

I was replying to the 2nd poster, as that is who I quoted. Not the OP.

noahliam:
I'm having the same problem. :roll_eyes:

Don't be so sure :wink: The error you are getting may depend on different causes, and since no one in this thread posted a detailed log of the error we can only wait for more information and keep guessing. Want to volunteer? Tell us which Arduino, where you get it from, which operating system, which version of Arduino software (1.0.3?), if it worked before or it's your first attempt, which serial port you are using, if the Arduino orange led blinks, if the sketch you are trying to upload compiles without errors (better use the 'blink' example to keep things simple). Then open the Arduino Preferences and tick the "Show verbose output during:" "upload" checkbox, try to upload, copy the error log at the bottom of the Arduino window and paste it in a new comment using [ code ] tags (the # icon above). All this information is well worth a thread of its own, don't be afraid to open yours.

Well... here is what I got on the "verbose" when I tried to load "hello world"

Binary sketch size: 2,586 bytes (of a 14,336 byte maximum)
C:\Documents and Settings\flavio\My Documents\Arduino\arduino-1.0.3\hardware/tools/avr/bin/avrdude -CC:\Documents and Settings\flavio\My Documents\Arduino\arduino-1.0.3\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega168 -carduino -P\.\COM3 -b19200 -D -Uflash:w:C:\DOCUME~1\flavio\LOCALS~1\Temp\build5216325044082371711.tmp\HelloWorld.cpp.hex:i

avrdude: Version 5.11, compiled on Sep 2 2011 at 19:38:36
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Documents and Settings\flavio\My Documents\Arduino\arduino-1.0.3\hardware/tools/avr/etc/avrdude.conf"

Using Port : \.\COM3
Using Programmer : arduino
Overriding Baud Rate : 19200
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done. Thank you.

Any ideas?

flaviocantinho:
Well... here is what I got on the "verbose" when I tried to load "hello world"

Is that something you created yourself?

flaviocantinho:
-patmega168 -carduino -P\.\COM3 -b19200 -D -

The board is set to "Arduino Diecimila or Duemilanove w/ ATmega168" or one of the other boards with "ATmega168" in the name.

Is what you what you have connected?

I had this error, and it wasn't working for me either.

Make sure to check the serial port using the Device Manager in control panel! Sometimes, disconnecting overnight and returning the next day may change it from COM3 to COM4 like it did for me, henceforth unable to sync the device and upload.

Tryed again with Brand new Nano v3, second out of two boards, trying to load "blink" from Arduino examples files.

Binary sketch size: 1,084 bytes (of a 30,720 byte maximum)
C:\Documents and Settings\flavio\My Documents\Downloads\arduino-1.0.3-windows\arduino-1.0.3\hardware/tools/avr/bin/avrdude -CC:\Documents and Settings\flavio\My Documents\Downloads\arduino-1.0.3-windows\arduino-1.0.3\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P\.\COM5 -b57600 -D -Uflash:w:C:\DOCUME~1\flavio\LOCALS~1\Temp\build4404955568642824635.tmp\Blink.cpp.hex:i

avrdude: Version 5.11, compiled on Sep 2 2011 at 19:38:36
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Documents and Settings\flavio\My Documents\Downloads\arduino-1.0.3-windows\arduino-1.0.3\hardware/tools/avr/etc/avrdude.conf"

Using Port : \.\COM5
Using Programmer : arduino
Overriding Baud Rate : 57600
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done. Thank you.

same problem
"Binary sketch size: 1,084 bytes (of a 32,256 byte maximum)

avrdude: stk500_getsync(): not in sync: resp=0x00 "

im having arduino uno bought from the dx. using windows xp, arduino 1.o.3 ide, arduino is connected in COM28…

I think retrolefty may be correct in my case . .the PC I use for projects/exc is from 2006, it worked perfect until after I had restored my PC to factory settings to fix some bugs. I think I just need to get the drivers up to date. My Arduino had a sketch loaded to it and was working fine, I just kept getting the error when I tried to write a new sketch. . I will work on updating my drivers and see if that is indeed the issue. I will post my resolution when I find it. Thanks.