avrdude: stk500_getsync(): not in sync: resp=0x00

We have the IMU Razor 9DOF SEN-10736 connected to an FTDI Breakout Adapter FTDI_Basic_Breakout_3.3_5V__SKU__DFR0065_-DFRobot which is in turn connected to the PC via a mini-usb cable.

When trying to upload Razor AHRS Firmware code https://dev.qu.tu-berlin.de/projects/sf-razor-9dof-ahrs/files version 1.4.1 using the Arduino IDE (v. 0022 - we tried 1.0.3 but that didn't work either), we get the following error message:

avrdude: stk500_getsync(): not in sync: resp=0x00

We have tried various suggestions that we have read on forums such as:

  • trying to hold the reset button, unplug, plug, hit upload and release the reset button
  • changing the usb cable
  • changing the COM port to COM8 on windows
  • we are sure we are using the correct baud rate (57600); we even changed it to 57600 for the COM port
  • we are sure we chose the correct board (Arduino Pro or Pro Mini (3.3V, 8MHz) w/ ATmega328) and serial port on Arduino

Could you please help us

Your boot loader might be crashed . Upload bootloader using avr pocket programmer

Version 1.0.3 is already very old. Many problems has been fixed. Please use the newest version (1.0.5 at the moment), and try to adapt the library.

That error indicates that there is no communication with the Arduino at all.
Please check the usb-to-serial path very careful, check the voltage levels and the RX/TX connections.

@oztastr, do not cross-post. Replies go here.