avrdude: stk500_recv() and avrdude: ser_open()

Hi all, I have started getting an "avrdude: ser_open(): can't open device "\.\COM6": Access is denied." error when trying to upload. And also an :avrdude: stk500_recv(): programmer is not responding error". Sometimes i'll get there ser_open() and then a few seconds later it will run into a stk500_recv() attempt cycle, and sometimes I just get the avrdude: stk500_recv(): programmer is not responding error.

As background it is a recently purchased uno r3 with the ide running windows 7.

The board was working great until I removed the mcu to use the board as a ftdi to communicate with an XBee.

Also while the MCU was removed I used the board as a power supply to play with a mosfet. I could've damaged the board while doing this because at several points while applying voltage to the mosfet all the lights on the board went out but came back on when the voltage was removed.

AND while trying to work with the XBee I pulled off one of the RESET EN solder dots :confused: I don't really understand what the dots function is, if somebody could enlighten me I'd appreciate it.

So after doing all that I have not been able to upload to the board.

To try to resolve this I have:

  • Checked that it is board shows up in the device manager (it does)
  • Made sure that the com port is the same as the one the ide is trying to upload to (it is)
  • Reinstalled the arduino driver
  • Reinstalled the IDE
  • Checked that when reset the Arduino light flashes a couple times to indicate it has a bootloader(it was for a while, but just doing it now it is not resetting..)
  • Enabled verbose uploading output to better see what it going on
  • Tried to reset the arduino at various times while uploading (before pressing the upload button and releasing once the first rx light appears, and after pressing upload for a few seconds)

Does anybody have any thoughts or suggestions? I've spent a couple of hours trying to figure this out and i'm not sure what to do now.

Did I burn the ftdi chip? did ripping off that solder dot catastrophically ruin the board?

Here is a copy of my error messages:

avrdude: ser_open(): can't open device "\.\COM6": Access is denied.

avrdude done. Thank you.

avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x41 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x41 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x41 avrdude: stk500_recv(): programmer is not responding ect. ect.

and here is a picture of the ripped of solder dot:

https://drive.google.com/file/d/0B0XkhlpP415pdk9wOFl5d3FSVzg/view?usp=sharing