avrdude: stk500_recv(): programmer is not responding avrdude: ser_send(): write

Salut tous,
J'arrive à téléverser sur UNO, mais pas sur NANO, voici ce qu'il me dit:

avrdude: stk500_recv(): programmer is not responding
avrdude: ser_send(): write error: sorry no info avail
avrdude: ser_recv(): read error: Accès refusé.

La NANO est toute nue, rien dessus...

Une idée?

Avec des variantes:

Arduino : 1.8.5 (Windows 10), Carte : "Arduino Nano, ATmega328P"

Le croquis utilise 5078 octets (16%) de l'espace de stockage de programmes. Le maximum est de 30720 octets.
Les variables globales utilisent 313 octets (15%) de mémoire dynamique, ce qui laisse 1735 octets pour les variables locales. Le maximum est de 2048 octets.

avrdude: stk500_paged_load(): (a) protocol error, expect=0x10, resp=0x00
avrdude: stk500_cmd(): programmer is out of sync
avr_read(): error reading address 0x0000
read operation not supported for memory "flash"
avrdude: failed to read all of flash memory, rc=-2
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00

Rien de branché sur les IO D0 et D1 ?
C'est une nano que tu as déjà utilisée ?

En faisant un Reset manuel aussi ?

Salut

Le premier message fait penser à un bootloader qui ne répondrait pas.

Un essai avec une NANO sans bootloader :

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00

Mais les deux autres messages ne correspondent pas.

As-tu ce problème avec une seule NANO ou plusieurs ?

@+

@+

J'ai souvent des problèmes de téléversement, faut changer de port, recommencer 2 ou 3 fois...

J'ai eu le problème avec mes deux NANOS. Elles ont déjà servi dans plusieurs montages.
J'ai des conflits avec un port BT et les ports série de windoz, alors je les sors du PCB, et je le connecte en USB, toutes pattes en l'air.

Je pensais ENCOOOOORE à un 'problème d'électricité statique', mais je commence à me demander si ça ne relève pas plutôt de la superstition que d'autre chose... Je suis vraiment TRES souvent emmerdé...

Elles ont passé la nuit dans une feuille d'alu, on verra aujourd'hui, mais IDE est vraiment instable, tout le temps, et c'est gavant...

Ce qui est flippant c'est que j'ai pas toujours les mêmes messages, mais c'est courant chez moi avec IDE...

Arduino : 1.8.5 (Windows 10), Carte : "Arduino Nano, ATmega328P"

Le croquis utilise 5078 octets (16%) de l'espace de stockage de programmes. Le maximum est de 30720 octets.
Les variables globales utilisent 313 octets (15%) de mémoire dynamique, ce qui laisse 1735 octets pour les variables locales. Le maximum est de 2048 octets.

avrdude: arduino_read_sig_bytes(): (a) protocol error, expect=0x10, resp=0x00
avrdude: error reading signature data for part "ATmega328P", rc=-3
avrdude: error reading signature data, rc=-1
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00

Ce rapport pourrait être plus détaillé avec
l'option "Afficher les résultats détaillés de la compilation"
activée dans Fichier -> Préférences.

Fait chier

Si tu as le courage, il y en a 11 pages ici, mais ce problème n'a pas de solution franche et nette. C'est dû soit :

  • à un câble défectueux
  • à un bootloader absent ou vérolé
  • à un problème de liaison série (genre pin 0 ou 1 utilisée)
  • à autre chose...
    On trouve ça et là des gens qui ont résolu le problème, moi c'est la poubelle qui m'a fourni la solution la dernière fois...

Bon bah alors c’est encoooooOOooore windoz qui merde avec le sports COM…
et j’arrive pas à installer linux >< niahhahahahaha trop bien

kammo:
Elles ont passé la nuit dans une feuille d’alu, on verra aujourd’hui

Je ne pense pas que cela serve à grand chose.
Si la décharge électrostatique a tué la carte tu peux la mettre à la poubelle. Je ne connais pas de circuits intégrés ayant des fonctions auto-cicatrisantes pour l’instant.

Est ce un arduino nano officielle ou chinois (CH340), dans le dernier cas, il faut utiliser la version IDE Arduino 1.6.5.