avrdude: stk500_recv(): programmer is not responding Error

Hi guys,

I’ve just run into this error and now the board wont update. It was working fine 5 minutes ago and would upload now it wont.

I’ve tried different USB cables and the trouble shooting guide on the Arduino webside with no prevail.

The system I’m using is Win 7 64-bit and Arduino 1.6.1 IDE and also tried 1.0.5 r1. I have also tried it on a Win 8 machine with Arduino 1.6.1

The board I’m using is a Freetronics Eleven R3 V2.0

The com port is selected right so is the board type.

All the correct drivers are installed and both the device manage and IDE pick up that its COM4 and I also tried changing the com port in device manager and then in the IDE and it still didn’t work.

When uploading code the RX light blinks 3 times then after a while blinks again the TX light doesnt blink at all.

I tried doing a loog-back through serial manager and everything seemed to be working.

I tried shift+upload and i get this error

avrdude: Version 6.0.1, compiled on Jan 15 2015 at 16:58:43
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino/hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : usb
         Using Programmer              : stk500v2
avrdude: usbdev_open(): did not find any USB device "usb"

If you have any other advice on what I should do, it would be greatly appreciated :slight_smile:

Thanks in advance.

This is the error code I get when trying to upload the Blink example code:

Arduino: 1.6.1 (Windows 7), Board: "Arduino Uno"


Sketch uses 450 bytes (1%) of program storage space. Maximum is 32,256 bytes.

Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.

C:\Program Files (x86)\Arduino/hardware/tools/avr/bin/avrdude -CC:\Program Files (x86)\Arduino/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM4 -b115200 -D -Uflash:w:C:\Users\Nathan\AppData\Local\Temp\build7337161514492371573.tmp/sketch_mar24a.cpp.hex:i 



avrdude: Version 6.0.1, compiled on Jan 15 2015 at 16:58:43

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2009 Joerg Wunsch



         System wide configuration file is "C:\Program Files (x86)\Arduino/hardware/tools/avr/etc/avrdude.conf"



         Using Port                    : COM4

         Using Programmer              : arduino

         Overriding Baud Rate          : 115200

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xb0

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xb0

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xb0

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xb0

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xb0

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xb0

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xb0

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xb0

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xb0

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xb0



avrdude done.  Thank you.



Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

If there could be a problem hogging the serial port then try pressing the reset button just before upload. It may take some practice.

I've tried numerous times pressing the reset button before pressing upload, after pressing it, 4 seconds after, none of which worked.

I could just have bad luck at pressing it or not the right timing

check these points

  1. is there any interface connected to pin Tx & Rx lines. if yes remove it & upload code

2)Usually above error come when bootloader crashed.Have you uploaded the code with infinite loop ??
is your LED 13 keep flickering or remain high ??

There is nothing plugged into the Tx & Rx.

I haven't changed anything on the blink example so it should upload.
LED 13 sometimes is on high and flickers. even when its off it gets there error

Inthat case ur bootloader got crashed. Just upload the bootloader it must work

AMPS-N:
Inthat case ur bootloader got crashed. Just upload the bootloader it must work

Is there a guide to doing that somewhere?

you might need to buy this

explination are properly explained in hook up section

Would it be just as easy to buy a new chip and replace it?

yes you have option ; u get chip with boot loader updated. If it is long term projects i recommened to go with Avr pocket controller.

Is that just in case it happens again?

Is this the same thin or similar?

just go with sparkfun product.they are authorized for arduino product. Still its cheaper than you suggested.

There are vendor sales some lower price ; make ensure good track record of selling boards.some of vendor ebay ; aliexpress sales product later these product wont work itself.

if you have capability to solve error you can go with it
http://arduino.cc/en/main/buy
its better go with above vendor near by location.

If you have a spare other board you could try Nick Gammon's bootloader sketch here.