avrdude: stk500_recv(): programmer is not responding not in sync: resp=0x00

I was using Arduino Nano for testing MPU9250 sensor, extruding data. For a few times uploading sketch everthing was great. But on the other day, I connect my usb cable to another (from Thunderbolt usb 3 to 2) usb port of my MacBook pro, since that I could not able to upload anything to arduino UNO, Nano which worked great last time.
I tried reinstall the FTDI, Arduino Software IDE but cant solve at all.
I also tried to burn bootloader but I could not even upload the Arduino SPI sketch to any functioning board.
Anyone know how to solve this?

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:01:35
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/cu.usbmodem1420
Using Programmer : arduino
Overriding Baud Rate : 57600
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude done. Thank you.

Is the selected port still the correct port?

Further you might willingly or unwillingly have upgraded the board manager to version 1.21 1.6.21 and you are using an older Nano (before 2018) or a clone. In that case, select 328P (old bootloader) from the processor menu. In that case it was just a coincedence that it no longer works.