avrdude: stk500_recv(): programmer is not responding

I recently bought the two following items:
http://www.phenoptix.com/collections/new-products/products/bare-bones-breadboard-arduino-compatible-kit-shrinkify-your-projects
http://www.phenoptix.com/products/usb-cp2102-usb-to-uart-converter-for-programming-shrimps-and-arduinos

I have wired them up like this:

I bridged the VCCs on the ATmega
I bridged the GNDs on the ATmega
I bridged the crystals with a 16MHz oscillator
Each of the legs of the oscillator is connected to a capacitor that is also connected to GND.
I have a wired up a reset circuit exactly like this: http://www.whatsmoke.com/wordpress/wp-content/uploads/2010/06/ATMega-Standard-Reset-Circuit.gif

I have installed the arduino IDE and the driver for the USB to UART connector (Index of /drivers)

I selected arduino uno (Tools->Board) and /dev/tty.SLAB_USBtoUART (Tools->Serial Port) and verified the example blink script. When I clicked upload, it failed and said: avrdude: stk500_recv(): programmer is not responding

I have tried /dev/tty.SLAB_USBtoUART and /dev/cu.SLAB_USBtoUART, I have tried holding the reset with no change. I still cannot load a script onto it. What am I doing wrong? Thanks!

I have also connected the 5v of the UART connector the the VCC, GND to GND, RX to TX and TX to RX.

Reset circuit is wrong.

Should consist of the resistor and pushbutton as shown, but rather than a capacitor to ground, you need a 0.1µF capacitor going from the reset pin to the DTR (or RTS) pin on your CP2102 adaptor - fortunately the adaptor you have is the quality part.

The alternative is to press the reset button briefly when you see the “Binary sketch size: xxxx bytes (of a 30720 byte maximum)” message on the IDE, but having the “auto-reset” circuit working makes it a whole lot easier.

And - if those connections do not work, try swapping TX and RX connections - it is often difficult to figure which goes to which, as “Transmit” and “Receive” depend on from which end of the connection you are looking.

CP2102 modules I have go tx > tx and rx > rx
PL2303 modules I have go tx > rx and rx > tx

As Paul says, fix your reset circuit first and then try swapping rx/tx and then report back.