avrdude: stk500_recv(): programmer is not responding

Hi All,

I'm having some troubles with a homemade Uno. It's an exact copy of this: http://www.hobbytronics.co.uk/datasheets/breadboarduino.pdf

It uses one of Sparkfun's FT232R Breakout boards.

I'm running Mavericks OS, which I believe has some driver issues thanks to Apple, so I have wiped the drivers provided by Apple and installed the correct drivers from here: VCP Drivers - FTDI

When I plug it in with my USB cable, I see both the RX and TX pins flash twice at the same time.
When I upload, the TX pin flashes 3 times and produces this:

Binary sketch size: 1,082 bytes (of a 32,256 byte maximum)
/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P/dev/tty.usbserial-A5025MJU -b115200 -D -Uflash:w:/var/folders/dw/bfvq4p9d033c_w8s4dmsj5b40000gn/T/build4280376479980068633.tmp/Blink.cpp.hex:i 

avrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/SimonRogers/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/tty.usbserial-A5025MJU
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.

If I attempt to burn the bootloader again, I get the exact same code.

(Note: the Atmege328p-pu I am using comes with a pre-burned bootloader. Allegedly it has been tweaked to work better with this type of breakout board.)

I'll gratefully receive any wisdom on this one.

EDIT: I've tried setting the board as Board > Uno, Board > Demi 328, Board > Nano w/ 328. I've got it going to .tty port as you can see in the code (but I've tried .cu) and I'm using the standard AVR ISP as the programmer.

I've been an absolute nonce! Please ignore.
I was reading that this problem was often linked to the reset not happening automatically, and that it needed to be pressed manually prior to upload. I knew this would happen automatically with my setup so then wondered if I'd actually put the switch onto my breadboard in the correct way afterall... apparently not. Orientating correctly has fixed my problems.