avrdude sync 0x00 error: different boards, weird behavior

Hi all,

I have this mind-boggling problem that I can't manage to solve, so I thought to share. Nothing like this either on the internet or the troubleshooting page.

There's an Arduino Ethernet embedded, doing things. The board holding the arduino extracts also the pins for programming (TX RX RST GND, optional +5) but I tried even directly (arduino off the board).

Now the problem is this: I did many attempts with various combinations of hardware but I have data contradicting each other. Let's say I have the following (giving them codes for ease of reading):

  • PU: programmer USB2Serial Light
  • PA: programmer ATAVRISP2 (Atmel)

  • E1: Arduino Ethernet

  • E2: Arduino Ethernet

  • U1: Arduino UNO R3

  • U2: Arduino UNO R3

  • M1: Arduino Pro Mini 5V/328

and this is what happens: - U1 and U2 programmed via USB cable: fine - U1, U2, E1, E2 programmed via PA: fine - E1, M1 programmed via PU: fine - all the others programmed via PU give:

avrdude: Version 5.11, compiled on Sep 2 2011 at 19:38:36 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "Z:\backed-up\software\arduino\arduino-1.0.1-windows\arduino-1.0.1\hardware/tools/avr/etc/avrdude.conf"

Using Port : \.\COM4 Using Programmer : arduino Overriding Baud Rate : 115200 avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Recv: . [00] avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done. Thank you.

PU RX LED blinks 3 times, corresponding to the 3 sends.

I tried: - both through my board AND directly (onboard linear connector) on E1, E2 - both through my board AND directly (with BB/cables) on M1, U1, U2 - both using and not using a 105 cap on the RST line - setting the IDE for different combinations of Programmer and Board (f.e. M1 loads with almost any 328) - checking the power feed w/ multimeter and oscilloscope: stable just around 5V and no noise - changing computer (two W7 Pro, one XP Pro SP3) - using different USB ports on each computer - oh and several attempts for each computer/port/component mixup, yes, it's weeks I'm around it, the collection of data took a long time but I wanted to be sure; if there's something consistent is that if it works, it does first try; if it doesn't, not even in hours and repeated attempts.

If only E1 was behaving like the others, that would be consistent and I'd know where to look; fact is that E1 loads first try without even blinking (well, it does, pun not intended :)) and the others don't. Thinking of a bogus bootloader, or 8U2 firmware, OK if it was one, but all of em? Sounds strange also that the comm sections of E2, U1 and U2 are gone all together, and however they aren't, since going back to programming with PA (E1) and USB cable (U1, U2) works fine.

Sure there's something I overlooked, if any of you has suggestions what to try/check for further analysis, I'm running out of places where to bang my head.

Thanks in advance /freeant