avrdude sync problem

Hello everyone, sorry for the repost, though i am interested in a kind of different question, so hopefully you wont mind.
Like many people, i have encountered the error avrdude: stk500_getsync(): not in sync: resp=0x00 while trying to upload my code to the board (Arduino UNO). I tried reinstalling the drivers, switching cables, checking ports and boards, hitting restart, rebooting the pc etc.. When this problem first arose, all i had to do was to restart the pc, but now this doesn't seem to work anymore, ultimately i ran out of options, it doesn't even want to load the simplest examples like the blinking led without anything connected to it. I am running windows 7 64bit, and have an Arduino UNO.
However, i noticed that on my device manager, the ports are displayed quite strange, and i have a feeling that something might be wrong here. In the picture below, in the red rectangle, this is what comes up when i connect my Arduino to the pc (the communications port appears). If i am not mistaken, shouldn't it say something like USB serial port (COM#)? Can the problem be here with the pc, and do you have any ideas how this could be fixed, because i have done quite a lot of browsing, and didn't find anything? Anyway, all help is welcome and i would be grateful, thanks.

I have the same problem. Is it on Windows 8? My problem happens on my Windows 8 PC. But on a Windows 7 Netbook, Programming works. I think you might have to resort to a different laptop/PC

Wow. I just posted a thread on the same problem. I found the problem initially on windows 8 but trying on vista and xp gave the same results.
I did found this thread on how to install arduino drivers for windows 8 and these instructions on installing the FTDI drivers (and I used one of these drivers)

Oh, I just see that our problems are not exactly the same: in my case the arduino is displayed under 'Ports (COM & LPT)' as 'USB Serial Port (COM11)', but this is the only difference.

Here's a link to the thread I made. Maybe it will interest you since out problems are similiar (in fact, if I saw this thread before posting mine I would possibly reply to this thread instead of making a new one).

Quite an annoying problem though, but it somehow relieves me to see that I'm not the only one struggling to get things to work.


Which IDE version are you using? Arduino 1.0.4 now has Microsoft signed drivers and eried's Enhanced IDE is very nice for installing on fussy Windows systems:

Another work around is a USB hub which will cause the device to enumerate on a different com port.

I just want to say thank you Simonas;
I follow the link for the Arduino Forum
the board is working now.


i triend the link, and downloaded the modified IDE, however it did not work. I tried out the board on a different computer, with win xp and was also unable to upload a program (i installed the drivers ofcourse), however, in device manager (in win xp), the arduino was displayed similarly like on my computer ( similarly like the photo i posted), that might suggest that in fact, something might be wrong with the actual board, any suggestions? :slight_smile:

Hmmm...this is very interesting. I have an Uno R2 that enumerates as a "Communications Port" and a Uno R3 that enumerates as a "Arduino Uno". Obviously, they run different firmware, but I was sure that it came up R2. Anyhow...

Have you tried to upload a sketch through the IDE to the Communications Port COM34?

Spcomputing, ofcourse, i tried changing ports (eg. from COM3 to COM 1, 2 ... , tried COM34, and different ones), however, got the same result. It is strange, that whenever i change the port number in device manager, arduino IDE seems to show that one port. Another interesting thing that i noticed is that whenever i try to upload any kind of program to the arduino, the tx and rx lights blink a couple of times, but are very dim, i didn't even notice that before, that means that something is being sent i guess... What do you think, maybe i should try to reset the actual board some way, perhaps you have any ideas how to do that and if it is possible at all when there is no communication?

By the way, i tried the loop back (Arduino Forum). And everything seems to work, though at first, everything got mirrored back, even when the specified pins were not connected, kind of strange... but after reconnecting, the board passed the test. When no jumpers are connected and i type something in, the rx led flashes, when the jumpers are connected, both the rx and tx pins flash upon imputing something in. This leads to believe, that perhaps the drivers and serial to usb converter on the board are working good, what are other possibilities?

This leads to believe, that perhaps the drivers and serial to usb converter on the board are working good, what are other possibilities?

The only one that remains is the bootloader on the Atmega328 is corrupted. When you plug power or USB into your Uno, do you get three fast flashes on the user LED marked "L"?