I’m using Dragino and Arduino Mega 2560 (Mega ADK actually, but they are almost the same).
I can upload firmware to Arduino Mega through web interface and it works perfectly, so the connection is OK.
But I need to use avrdude (or any other if You can suggest any) to upload a hex file to Arduino from Yun shield.

I rely the following preferences from averdude.conf

id = “linuxgpio”;
desc = “Use the Linux sysfs interface to bitbang GPIO lines”;
type = “linuxgpio”;

for DS1 board

reset = ~18;

for DS2 board

reset = ~7;

for DS2_B board

reset = ~20;
sck = 18;
mosi = 6;

mosi = 21;

miso = 22;

But maybe GPIO that i specified are wrong? I tried it also for Arduino UNO. And it does not work, Can You help me with this?
I use command
avrdude -c linuxgpio -p atmega2560 -U flash:w:led28.hex -b115200

And receive
avrdude: AVR device not responding
avrdude: initialization failed, rc=-1

I would be very grateful for Your help.

P.S. I also tried the following
GPIO18 <----> SCK
GPIO22 <----> MISO
GPIO21 <----> MOSI
GPIO20 <----> /RESET
GPIO23 <----> SS

It didn’t work

P.P.S. I also tried to use Arduino UNO
Using the command

avrdude -p atmega328p -c linuxgpio -U flash:w:led28.hex -U efuse:w:0x00:m -U hfuse:w:0xdd:m -U lfuse:w:0xff:m

The averdude command that I wrote above is wrong. Everything was fine with averdude.conf