bad DUE programming port USB

The IDE no longer recognizes the programming port on my DUE (ttyACM0 not found). If I move the cable to the Native port, everything works. In the programming port, I do see power LEDs on, but it won’t upload and a sketch won’t print to the monitor. I assume one or more of the pins in the connector must have lost connection?? Any magic that might be applied?

I have tried another cable and tried hooking to a different computer … no luck.

(at least, it works with the Native port)

Here some 'magic' that worked out for me a long time ago.

  1. Power the DUE.
  2. Press the ERASE button.
  3. One second later (while pressing the erase button) press the RESET button.
  4. One second later release both buttons (erase and reset).
  5. Now try your programming port.

Regards, Palliser

Nope, that incantation did not help.

sometimes it also says " SAM-BA operation failed"

You could be facing a programming driver issue. Try to re-installed it. I don't know you op. sys. but there a link from Arduino: Remember that each USB port of DUE has its own driver. Good luck!

Sorry for not providing enough detail. No drivers to install. Host machines are Ubuntu 12.04 and 12.10 and using IDE 1.5.5 it's looking like a hardware problem on DUE connector ...

check with another cable! Thats almost a cable problem! In SAM-BA mode the DUE seems to be more sensible to impedances/resistance issues.