Bad Nanos

Just looking at your board makes me think it's a clone; the pushbutton is different, the ISP port doesn't have a connector installed, and there's no little piece of what looks like Kapton tape on top of the USB connector.

  • Arduino_Board.jpg 563.4 KB downloaded 10 times

I have two Nanos that are refusing to work under Windows 7 as well; they show up as COM26 USB serial ports, but no other identification. If I connect an Uno to the same system using the same USB port (with a different cable, obviously, as they're different connectors) it identifies it as an Arduino Uno in addition to showing the COM port. I can program the Unos just fine from the IDE, but I'm getting timeouts trying to do the same with the Nanos. The docs elsewhere on this site imply there are two different flavors of the Nano, and that you can select which processor yours has from the IDE, but mine only shows ATMEGA328P (which is correct, based on the chip markings) and ATMEGA168. The docs said there was an option for "ATMEGA328P (Old Bootloader)" https://www.arduino.cc/en/Guide/ArduinoNano#toc4 but I'm not getting that. The Nanos were both purchased a couple of months ago, so I'm not sure if they're old or new.

I've tried removing and reinstalling the drivers for the Nano; in Device Manager the hardware ID is "FTDIBUS\COMPORT&VID_0403&PID_6001". I tried the CH340 driver; it caused windows to BSOD over and over until I restored the previous known good configuration whew. One really odd thing that happened was that before I tried the CH340 driver, I told the IDE that I had an "Arduino Uno" on COM26 (instead of a Nano) and it appeared to upload to the board correctly! The red LED flashed several times, which it doesn't (or only very briefly when it does) if I tell the IDE I've got a Nano during uploading, and now the "Blink" example is running on the Nano, based on the "L" LED flashing once/second or so.

Any suggestions, or do I now own the world's most complicated LED flasher?

-Bill

PS - I neglected to note that the IDE is version 1.8.5.

If they show up (as COM port) in device manager, reinstalling the drivers is useless.

Go to Board manager and install the updates. Now you will see "old" and "new" bootloader options.

The "new" Nano's have the same bootloader as a Uno. So indeed, that should work as well ;)

@culturedropout, do not hijack. Thread split.