Baffled...My Arduino Uno and serial port have disappeared from Win7(64bit)...

Hi..I could really use some help. Yesterday I purchased an Arduino Uno for use with my Windows 7 Professional 64bit system. The setup and driver installation went fine and for all of yesterday I was able to happily upload my sketches and have them run.

Today I was working on a sketch just to manipulate a few LED's on a breadboard and my first few uploads worked as normal. I decided I wanted to change some arbitrary values and went to upload it again, when a prompt popped up saying:

"Serial port COM3 is no longer available. Would you like to use COM1 instead? (paraphraed)

I declined because my Arduino was not on COM1, it was on COM3. I then went to device manager to see what happened, and sure enough my COM3 port had disappeared...and furthermore my Arduino was nowhere to be found on the device list. I tried unplugging the USB and plugging it back in, and while the Arduino appeared to power up as normal, Windows gave no indication that a device had been connected and my device list did not update. I then decided to restart my computer before attempting to plug it back in and the result did not differ.

Here are images of both my device list as seen in device manager, and the physical state of my Arduino. Both were created minutes before this post and it's safe to assume nothing will have been changed after this post is submitted.

Details about this image: -Both the green and yellow onboard LED's are powered on and solid (I shouldn't have used the camera flash :p) -The wires are connected to pins 3,7,8,10 and ground. Also connected to a breadboard with 4 LED's -The other end of the USB connection is connected to one of the front USB 2.0 ports on my computer which I have verified is -functional. (Also tried the Arduino on a different port, no difference) -Unfortunately I can't tell if the Arduino is properly running my current sketch or not because it requires serial input to power on the LED's. (that is, if the program was running properly, all the LED's would be powered off until input is received)

So yeah I am completely at a loss, I have combed through Google and earlier forum posts but haven't come across a solution to my problem yet so I'm really hoping someone can help me, I'd hate to think that my brand new Arduino that I just bought yesterday is already malfunctioning.

Thanks in advance for any help :)

I can see LEDs but I can't see resistors. Are there any there, and if so, what value are they?

[quote author=Nick Gammon link=topic=193228.msg1427829#msg1427829 date=1381731860] I can see LEDs but I can't see resistors. Are there any there, and if so, what value are they? [/quote]

There is no resistors on the breadboard if that's what you mean.

Right. Better read this then:

http://www.thebox.myzen.co.uk/Tutorial/LEDs.html

There are several web sites and schematics on the web that suggest you can attach an LED directly to an Arduino output pin with no current limiting resistor. They are wrong, and following them will damage your Arduino.

You have possibly damaged your Arduino. Try running it with everything disconnected (apart from the USB cable of course).

[quote author=Nick Gammon link=topic=193228.msg1427835#msg1427835 date=1381732251] Right. Better read this then:

http://www.thebox.myzen.co.uk/Tutorial/LEDs.html

There are several web sites and schematics on the web that suggest you can attach an LED directly to an Arduino output pin with no current limiting resistor. They are wrong, and following them will damage your Arduino.

You have possibly damaged your Arduino. Try running it with everything disconnected (apart from the USB cable of course).

[/quote]

When I disconnected all the wires, and plugged it back in, the device re-appears for a few seconds and then disappears again. So I guess the conclusion we can draw is...I've damaged something. Aw man, after one day how could this happen :( Especially because my friend is an engineer and picked out all the components for me to buy. Well that's 40 bucks down the drain...Anyway, thanks for your help.

It looks like you have the chip in a chip socket. You will probably resurrect it by replacing the processor chip for around $5.

At least you know why, now. I have quite a few of those boards and all but one is still working, and that one I think I zapped with an incautious static charge.

You might want to have a word with your engineer friend, too. He should have advised you to use current-limiting resistors.

The processor chip is not necessarily the damaged part, but for $5 or so it is probably worth trying. Meanwhile get some 220 ohm or so resistors for use next time.

[quote author=Nick Gammon link=topic=193228.msg1427856#msg1427856 date=1381733749] You might want to have a word with your engineer friend, too. He should have advised you to use current-limiting resistors.

The processor chip is not necessarily the damaged part, but for $5 or so it is probably worth trying. Meanwhile get some 220 ohm or so resistors for use next time. [/quote]

Yeah, I'll definitely try it. I'll be really pleased if I can resurrect it for such a small cost. Thanks very much for the suggestion. I'll definitely talk to my friend too because he is also connecting LED's directly to his board. (which still works fine after months of doing so, lucky for him.)

Not an electronic engineer, then?

These are fun boards, and you can do lots of great stuff with them, so don't be discouraged.

You do however need to treat them with a bit of caution. Those traces on the processor chip are only microns wide, and too much current will just melt them.

This morning I was able to try to hook up my Arduino to a laptop running Ubuntu 12.04 and I was able to upload and run sketches as normal. Afterwards I re-connected the Arduino board to my original PC where the problems started, and everything is working fine again…I guess the board isn’t damaged after all…lucky me :slight_smile: As a bonus, now I know not to connect LED’s directly to my board as well.

However, I still have no explanation as to how this problem occurred nor how it resolved itself. Since I can rule out damage to the device itself and also taking into account what cachemagic said, I’m starting to think that it has something to do with the driver and Windows systems.

Could this be possible? Any other theories? Personally I’d like to know what to do if this happens again.

One possible explanation is that the heavy current drain did something. There is a programmable fuse on the board which may have blown and then reset itself.

Also on my Mac sometimes it detects high USB current and turns off the USB port (usually when I do something wrong!). Unplugging and replugging (and rebooting sometimes) can fix that.