Bash to send command to Arduino

Dear all,

I am trying to send a command from a bash shell to my Arduino Uno.

I have the following code running on the Arduino:

int LedPin = 13;
int val = 0;

void setup() {
  Serial.begin(9600);
  pinMode(LedPin, OUTPUT);
}

// Read Value from serial and set a led high or low
void loop () {
  val = Serial.read();

  if (val == '0') {
    digitalWrite(LedPin,LOW);
  }

  if (val == '1') {
    digitalWrite(LedPin,HIGH);
  }
}

From bash, I can set the led high or low using screen and then press 0 or 1:

virtualmix@bluedragon:~$ screen /dev/ttyACM0

I would like to set the led high or low using echo:

echo 1 > /dev/ttyACM0

But it doesn't work.

Am I doing it wrong? Is there any known issues using the echo command, or anything I have missed out?

Any help appreciated :-)

Thank you!

I would guess that screen opens the serial port once, and keeps it open, and that echo opens the port, sends the data, and closes the port.

Opening and closing the serial port causes the Arduino to reset. The echo command sends the data before the Arduino is ready to read it, so it gets lost. The immediate reset causes the action, even if the data was received to not be executed.

There are ways to modify the Arduino to prevent a reset on the opening of the serial port.

Your arduino code does not check if there is a character on the serial port, check - http://www.arduino.cc/en/Serial/Available

#DEFINE LEDPIN 13   

char val;

void setup()
{
  Serial.begin(9600);
  pinMode(LEDPIN , OUTPUT);
}

void loop ()
{
  if (Serial.available() > 0) 
  {
    val = Serial.read();
    if (val == '0')
    {
      digitalWrite(LEDPIN ,LOW);
    }
    if (val == '1') 
    {
      digitalWrite(LEDPIN ,HIGH);
    }
  }
}

Hello since you are using linux why not try gtkterm if you have graphic envirement ofcorse to test it. If not you should this example to configure the port stty -F /dev/ttyS0 ispeed 9600 ospeed 9600 -ignpar cs8 -cstopb -echo

In my case 9600 baud, no parity, one stop bit.

Then wrote the data you need to send into a file (using hexedit) and send the file's contents:

cat commando0.dat > /dev/ttyS0 Also check if you port is ttyS0!!

Thank you so much to all of you for your reply.

Hugo007 was right, the problem is due to the serial port being closed after each connexion and the Arduino restarting every time because of its auto reset feature.

Anyway, I have tried a few different solutions and investigate this issue a bit further but it does not seem to have an elegant solution. So far, the best solution I have found, but not tested, is to plug a 120 Ohm resistor between 5V and reset pin. I couldn't find any "software solution" that successfully disabled the auto reset feature.

Also, I played a bit with gtkterm and it seemed similar to "screen" in some ways but does not satisfy my need to send command directly from a bash script.

Thanks again for your support and if there is anything new, I am still open to discuss this issue.

-Virtualmix-

There is a hardware solution - turn hardware flow control off with stty, and it won't toggle the DTR pin, thus avoiding reset.

@Aeturnalus: Thank you for your reply. Do you know the exact command?

So far I tried several stty command without success... I have spend about 4 hours to try do this and I am now about to give up my project...

Try this: stty -F /dev/ttyUSB0 -hupcl

Seems to work on my computer.

Thanks Aeturnalus. I tried this command in many different ways but it doesn't disable auto reset feature on my Arduino.

virtualmix@computer:~$ stty -F /dev/ttyACM0 -hupcl
virtualmix@computer:~$ echo 1 >/dev/ttyACM0

The board keep reseting :-/

Strange - it seemed to work for me. Have you tried running it as root?

virtualmix@computer:~$ sudo su
[sudo] password for virtualmix: 
root@computer:/home/virtualmix# stty -F /dev/ttyACM0 -hupcl
root@computer:/home/virtualmix# echo 1 >/dev/ttyACM0

The board still reset... So I tried to change the permissions:

root@computer:/home/virtualmix# chmod 777 /dev/ttyACM0 
root@computer:/home/virtualmix# stty -F /dev/ttyACM0 -hupcl
root@computer:/home/virtualmix# echo 1 >/dev/ttyACM0

But it did not work, my Arduino still reset.

The stty command disables hangup - that is, it keeps the serial connection open. Have you tried seeing what happens if you do this:

~$ sudo stty -F /dev/ttyACM0 -hupcl
~$ echo 1 > /dev/ttyACM0
~$ echo 1 > /dev/ttyACM0

Does it reset twice, or just once? On my board, the first echo command resets, but the second one doesn't.

Thanks for for help. I did what you suggested but the board still reset.

Sorry I didn't read your previous post properly: The board reset twice.

(I know this is a old post)

For anyone wondering the solution is to put a 10uf cap between reset and gnd. This stops the board from resetting

Hi all, I faced exactly the same problem as described above:

  • When character device opens, Arduino resets.
  • If I wait for 3 sec after open (wait until Arduino boots), communication works great, however my Arduino counts things and I would like to get back the result - so reset is not acceptable.
  • stty -F /dev/ttyUSB0 -hupcl works during tests with my laptop (Acer - Ubuntu 19.04) however at the final place with a router (TP-Link - LEDE/OpenWRT) does not.
  • connecting a 150 Ohm resistor to 3.3V - 5V or put a 10 uF capacitor is not an option because I would like to upgrade my Arduino remote via USB/IP, so I needed a "soft" reset-inhibit.

My solution: I sacrificed one pin - connected to reset pin, which is

  • initialized as OUTPUT-HIGH (actually first initialized as INPUT_PULLUP than OUTPUT to be sure we do not get reset during setup).
  pinMode(RESET_PULLUP_PIN, INPUT_PULLUP);
  pinMode(RESET_PULLUP_PIN, OUTPUT);
  • Upon request I "release" = put to high impedance, so when programming need a reset, it works.

I already have a communication part of my Arduino program (get commands from USB, do the work, respond to those commands), so I added this snippet:

if (strcmp(command,"PROG")==0) {
      pinMode(RESET_PULLUP_PIN, INPUT);
      Serial.println(F("RESET pin RELEASED"));
    }

Works as expected. My 2 cents.

v_mark: Hi all, I faced exactly the same problem as described above:

  • When character device opens, Arduino resets. ...

that is the very essence of the serial communication and the concept of Arduino using DTR to reset for programming.

For my part I am connecting Arduino mini pros directly from TX-RX to the GPIO uart and don't experience any reset upon calling the serial report or serial plotter. [/list]

I found a working option on command line - Bash, serial I/O and Arduino - Stack Overflow

"

I get the same problem too. I use Arduino Uno with Ubuntu 12.04. After a few hours of searching and trying, I find out that Arduino will reset when the serial device is opened for the first time,but will not reset when the serial device is opened again.

So, run command - echo “input string” > /dev/ttyXXX in bash will reset Arduino and send “input string” immediately. Arduino need take some time to initialize, and is not quick enough to receive this string. cat /dev/ttyXXX will reset Arduino too.

When /dev/ttyXXX is opened in somewhere firstly, these commands will work.

Here is my solution:

  1. open /dev/ttyXXX by redirecting /dev/ttyXXX to file description 3

exec 3<> /dev/ttyXXX

  1. wait for Arduino’s initialization

sleep 1

  1. communicate with Arduino

echo “input something” >&3

cat <&3

  1. close /dev/ttyXXX

exec 3>&-

"