batterien entladen sich?

hi

ich hab meinen NANO+stepper+servo mit einem batterieblock 4x AA Mignon 1,5V verlötet.. vorher beim testen hat alles geklappt, und verlötet geht nix mehr.. ich habe schon 3 packs neue batterien geöffnet und nix tut sich.. wenn ich die batterien entferne und USB anschließe läuft alles wie gewollt.

frage.. kann man da irgendwas falsch machen, dass sich die batterien entladen oder so?
ich habe den batterieblock wie folgt verlötet

V -> Vin on NANO
GND -> GND on NANO

dann vom NANO ausgehend:
D9 -> Signal on Servo
D2-D5 -> Stepper
5V -> Stepper Vin
5V -> Servo Vin

6V sind zu knapp für Vin. An dem Spannungsregler fallen etwa 1,1-1,2V ab (oder genauer, die Spannung muss abfallen damit er richtig regelt):

Seite 6, Dropout Voltage

Der Umschalttransistor auf Vin wird nicht schalten weil die Spannung zu tief ist.
Außerdem wenn es funktionieren würde, würde der Spannungsstabilisator überhitzen weil der Strom zu hoch ist.
Grüße Uwe

Nimm doch ein 5 Volt Powerpack und schließ das an USB an.
Da hast du keinen Verlust am Regler.
Du musst nur darauf achten, dass dieses nicht abschaltet, wenn zu wenig Strom fließt.

Zusatzinfo:
Nicht jedes Powerpack kann gleichzeitig Laden und ein externes Gerät versorgen.

Grüße Uwe

hi jungs… vielen dank für die infos :slight_smile:

habt ihr evtl. einen tipp für so ein 5v powepack? suche grad aber kann nichts finden… nur so riesen-akkus… ich bräuchte schon etwas kleineres, da mein projekt nicht so viel platz hergibt.

AdmiralCrunch:
hi jungs… vielen dank für die infos :slight_smile:

habt ihr evtl. einen tipp für so ein 5v powepack? suche grad aber kann nichts finden… nur so riesen-akkus… ich bräuchte schon etwas kleineres, da mein projekt nicht so viel platz hergibt.

Also bei Amazon gibt es doch eine Riesen Auswahl.

Eine Powerbank ca. 2000mAh ist kleiner als 4Mignon-Zellen.

ach da war ich doch.. nur war ich verwirrt, weil ich dachte das würde anders aussehen.. mhhh.. die teile sind ja echt sperrig.. probleme:

  1. ich habe halt nur begrenzt platz für die stromversorgung.. so 6x6cm ist ok.. alles dadrüber wird nicht gehen..

  2. das ganze soll in eine geschlossene box,.. der anwender wird nun erst an 4 stellen mit schaltern den stromkreis schließen müssen und erst dann soll strom fließen, der NANO angehen und arbeiten .. kann ich das auch einfach so mit einem usb-kabel machen? .. einfach durchschneiden und verbindungen dranlöten?

Du brauchst eine Powerbank ohne Einschaltknopf. Die haben meistens die Spannung dauerhaft anliegen. Wie oben geschrieben, schaue dich mal bei den kleinen Bänken um.

Was du noch testen könntest: Nimm NiMH-Akkus statt Batterien. 4Stk volle Akkus sollten ca. 5V statt über 6V wie bei den Batterien bringen. Du kannst bei Akkus direkt in den 5V-Pin des Nanos gehen und den Spannungsregler umgehen. Du darfst dann nur niemals echte Batterien verwenden.

Du darfst dann nur niemals echte Batterien verwenden.

Eine Diode(1N4001 oder so) am 5V Pin würde sowohl Verpolungsschutz wie 6V → 5.4V bieten…

Mach die Diode dran und vor allem schliess das Servo und den Stepper direkt an die Batterie. Falls die 6V vertragen

hi

nur damit ich das richtig verstehe..

NANO 5V -> 1N4001 ->batterieblock mit was genau? 1,5V AA oder diese NiMH-Akkus?

Neben der Powerbank wurden folgende zwei Vorschläge gemacht (ich darf das mal bebildern wie ich es verstanden habe): :slight_smile:

In #9 hat Theseus NiMH-Akkus vorgeschlagen, die haben ca. 1,2 Volt und 4 Stück also ca. 4,8 Volt. Da wird keine Diode gebraucht. So würde ich das auch machen (hab ich auch schon öfter, hat bei mir immer gut funktioniert).
Also so:
Nano_NiMH.png

In #10 und #11 haben michael_x und ElEspanol “normale” Batterien vorgeschlagen, die haben ca. 1,5 Volt (wenn voll), 4 Stück also ca. 6 Volt, da kommt die Diode ins Spiel. Voraussetzung: Stepper(Driver) und Servo machen da mit. (Hab ich auch schon eingesetzt, es waren aber keine Stepper und Servos beteiligt).
Wäre also so:
Nano_Alkali.png

Verkabelung von Servo und Stepper laut deinen Angaben im Anfangsbeitrag.

Ich mag ja diese “Fritzing-Bildchen” eigentlich nicht so sehr, aber von Zeit zu Zeit kann man sich da schon bedienen finde ich. :slight_smile:

Du kannst auch einfach nur 3 Batterien nehmen.
Der ATmega läuft auch mit 4,5V hervorragend.
Er läuft auch mit 2V, dann müßtest du aber die Taktfrequenz runter nehmen.

guntherb:
Du kannst auch einfach nur 3 Batterien nehmen.
Der ATmega läuft auch mit 4,5V hervorragend.

Allerdings muss man aufpassen, dass man nicht unter 4V kommt, wenn der Stepper plus der Servo läuft, weil dann der BOD den Arduino abschaltet/resetet.

uxomm:
Neben der Powerbank wurden folgende zwei Vorschläge gemacht (ich darf das mal bebildern wie ich es verstanden habe): :slight_smile:

In #9 hat Theseus NiMH-Akkus vorgeschlagen, die haben ca. 1,2 Volt und 4 Stück also ca. 4,8 Volt. Da wird keine Diode gebraucht. So würde ich das auch machen (hab ich auch schon öfter, hat bei mir immer gut funktioniert).
Also so:
Nano_NiMH.png

In #10 und #11 haben michael_x und ElEspanol “normale” Batterien vorgeschlagen, die haben ca. 1,5 Volt (wenn voll), 4 Stück also ca. 6 Volt, da kommt die Diode ins Spiel. Voraussetzung: Stepper(Driver) und Servo machen da mit. (Hab ich auch schon eingesetzt, es waren aber keine Stepper und Servos beteiligt).
Wäre also so:
Nano_Alkali.png

Verkabelung von Servo und Stepper laut deinen Angaben im Anfangsbeitrag.

Ich mag ja diese “Fritzing-Bildchen” eigentlich nicht so sehr, aber von Zeit zu Zeit kann man sich da schon bedienen finde ich. :slight_smile:

hey sauber… viele lieben dank… :slight_smile: … ich denke ich werde die lösung mit der diode und den 1.5V batterien nehmen… aus angst, dass die NiMH-Akkus nach ausgiebigen testen nicht genug strom haben.

AdmiralCrunch:
hey sauber.. viele lieben dank.. :slight_smile: .. ich denke ich werde die lösung mit der diode und den 1.5V batterien nehmen... aus angst, dass die NiMH-Akkus nach ausgiebigen testen nicht genug strom haben.

Die Akkus würdest du ja vor dem großen Moment noch mal entsprechend aufladen. Da hätte ich bei den Batterien mehr Sorgen.

NiMH haben meist einen geringeren Innenwiderstand als Akali-Mangan Zellen (von Zink Kohle ganz zu schweigen) und können daher einen höheren Strom liefern.

Theseus:
Die Akkus würdest du ja vor dem großen Moment noch mal entsprechend aufladen. Da hätte ich bei den Batterien mehr Sorgen.

das ist ja u.a. auch ein problem.. ich verschenke die box, nur wann die aktiviert wird, weiss man nicht.. es kann u.a 4-5 wochen dauern bis die box aktiviert wird.. das muss also bis dahin gehen..

ich habe mir gedacht ich teste das ausgiebig, dann tue ich frische batterien rein.. teste noch genau 1x und dann ist gut, sollte doch halten oder? .. muss auch nur 1x - 10x funktionieren