Bekomme ARDUINO+433 RX Modul v. Conrad nicht hin

Blöde Frage: das Empfangsmodul hängt jetzt nicht mehr an Pin 0? Grüße Uwe

Ich habe es an PIN 2 gehängt. Klemme den ganzen Arduino vom USB ab und betreibe es mit separatem Netzgerät. Ist also getrennt vom PC. Es soll ja auch später ohne PC die Daten annehmen und darstellen.

Wird nicht zufällig aus "a" "0" und aus "g" "6"? Was ist wenn Du die Zahl Null sendest?

Hi,

aus der Ziffer "0" wird " ", also Leerzeichen. Aus der Ziffer "6" wird "2".

Aus einer ASCII Textdatei, die das enthält

v1v2v3v4v5v6v7v8v9v10
hello welt

wird

http://www.youtube.com/watch?v=iLXgQzCSrEc

Ich raffe es nicht...

Ich hab's gefunden ;D ;D ;D ;D ;D Dank NewSoftSerial habe ich mal folgendes gemacht:

NewSoftSerial mySerial(2,3,true);

Laut Doku NewSoftSerial myInvertedConn(7, 5, true); // this device uses inverted signaling. Das aber bedeutet, dass der Sender, der hier gebaut ist

http://www.roboternetz.de/phpBB2/viewtopic.php?p=6276

(großes Bild weiter unten) entweder invertiert sendet oder ich habe das falsch verdrahtet, sodass ich dadurch das Signal invertiere. Es ist mir peinlich diverse Leute damit aufgehalten zu haben und dann liegt der Fehler wahrscheinlich im Sender... Sorry dafür und 1000 Dank!!!

So, nun kann ich endlich meinen "wasauchimmer" Sender bauen :), mit dem ich dann Messages an das kleine Empfangsmodul senden kann.

Im Endergebnis muss ich aber sagen, dass alles über Manchester encoding etc. garnicht zutrifft. Ich sende seriell und empfange seriell und amit hat es sich erledigt...

Danke an Webmeister und uwefed, ohne den Tipp mit (New)SoftSerial hätte ich wohl in Stein gebissen :)

Wäre doch gelacht, wenn wir das nicht hinbekommen hätten. ;) Ich würde mich freuen, wenn du deine weiteren Projektfortschritte hier posten würdest, scheint ja 'ne ganz interessante Sache zu werden.

Moinsen,

so oder so ähnlich habe ich mir das später mit dem "ASerMo" vorgestellt:

http://www.youtube.com/user/de8msharduino#p/u/0/eMPeG8c2Ztc

Die Daten werden schon "in Echt" per 433 MHz Brücke an den Arduino gesendet, füllt einen Buffer von max 1000 Byte. Nur das Menu nach "Buffer filled!" ist noch unfunktional...

Mal sehen, was ich daraus mache... ;) Habe noch keine genaue Marschroute. Aber per wscript Daten durch die Luft an Arduino senden klappt ;D bis maximal 1200 BD. Ich glaube getestet zu haben, dass bei 2400 BD schon nur noch Mist ankommt.

'n Abend.