[Besoin d'aide] Erreur avr-gcc lors de la compilation

Bonjour,

J’ai acheté deux arduino Nano sur Ebay, mais lorsque je veux compiler un programme, j’obtient une erreur avr-gcc et je ne sais pas pourquoi.

J’ai mis à jour l’Arduino sous 1.6.10 mais mon problème est toujours présent, j’ai également essayé de le mettre à jour via le gestionnaire de périphérique, mais il est afficher un /!\ jaune… Donc j’ai essayé d’installer les drivers de VCP mais cela ne marche toujours pas…

J’ai cherché plusieurs heures sur pleins de forum anglais mais je n’ai rien trouvé.

Quelqu’un aurait-il une solution s’il vous plaît ?

Merci bien et bonne journée

Un conseil : vire en urgence cette version 1.6.10 La dernière fonctionnelle est la 1.6.5. Toutes les suivantes c'est de la fuite en avant.

Le message dit que l'IDE "a oublié" de compiler la librairie statique : le core.a et sur ce coup c'est vraiment du n'importe quoi.

Autre pb possible (en plus du précédent) : les nano de l'empire du milieu utilisent le CI CH340G comme interface USB/UART. Le driver de ce circuit n'est pas livré avec l'IDE (quelquesoit la version) donc si tu es avec Win$$$ il faut que tu télécharge le pilote du CH340G et que tu l'installe si ce n'est pas déjà fait.

En effet, je n'avais pas les bon drivers... Et cela fonctionne mieux maintenant, mais j'ai l'impression que la compilation est beaucoup plus longue que avec un FTL232..

Merci beaucoup pour ton aide !

mais j'ai l'impression que la compilation est beaucoup plus longue que avec un FTL232..

Les circuits FTL232 ou CH340G n'ont strictement , mais absolument strictement rien à voir avec la compilation. Ce qui fait qu'elle te parait plus longue c'est que maintenant la librairie statique" core.a" est construite alors qu'avant elle ne l'était pas.

D'accord, donc elle est reconstruite à chaque nouvelle compilation ? Du coup, est-ce possible d'éviter sa histoire de gagner du temps ?

Et je viens de remarquer que maintenant j'ai des message " Warning.... "

http://prntscr.com/arua1r

Et je vois pas du tout d'ou sa pourrait venir...

Si tu as un peu de temps pour m'aider sa serait bien gentil :)

La librairie statique core n’est plus reconstruite à chaque compililation depuis au moins 2 ans.
La librairie statique core.a est reconstruite a chaque ouverture de l’IDE.
Tant que dans la même session de l’IDE tu ne change pas de carte elle est n’est pas reconstruite.

Arretez de mettre les message d’erreur ou warning sur des sites à la mord moi…
Mettez les simplement en citation.

Ce n’est pas moi qui pose les questions et je n’ai pas nullement l’intention de faire un copier coller d’une adresse dans un nouvel onglet que je suis obligé d’ouvrir pour pouvoir lire le fameux warning.

Quelle version de l’IDE utilise-tu ?
Si c’est au dessus de 1.6.5 tout peut arriver.

J'utilise la version 1.6.5 de l'IDE,

Voila les messages :

WARNING: Category '' in library EEPROM is not valid. Setting to 'Uncategorized'
WARNING: Category '' in library SPI is not valid. Setting to 'Uncategorized'
WARNING: Category '' in library SoftwareSerial is not valid. Setting to 'Uncategorized'
WARNING: Category '' in library Wire is not valid. Setting to 'Uncategorized'
Warning: platform.txt from core 'Arduino AVR Boards' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.

J'ai comme l'impression qu'il y a des mélanges de versions différentes. Comme on peut installer autant de versions que l'on veut a condition qu'elles soient dans des répertoires in dépendants je ferai une nouvelle installation de la 1.6.5 en partant de zéro.

D'accord merci, je vais essayé sa se soir

Bonne journée