Big capacitor near microcontroller - Circuit stops working

Hello guys,

I have a circuit and when I put a big capacitor (330uF) near the atmega, the atmega gets stuck after running for a while. When I discharge the capacitor the circuit works again for a while and then stops again. On oscylloscope, i saw that the circuit stops working after the capacitor charges.

If I take that capacitor out, the circuit works perfectly.

I have an atmega168 running at 8mhz, with external crystal, and in the board there are also shift-registers and uln2803 drivers to control a LED matrix.

Does anyone knows what's happening? The circuit is working, as I took the capacitor out, but I'd like to know what happened so i don't make the same mistake in future projects.

Thanks for any help...

What is the big cap connected to? From your parts listed, I can't see any reason for it to be across anything but power & ground.

Exactly, it`s connected between power and ground... I forgot to mention, the capacitor is eletrolytic

Electrolytic, so it's polarized? Not installed backwards?
Got a schematic we can look at?

Already checked that... it's on the right direction...

So, back to reply #3: Got a schematic we can look at?

Here's the schematic...

DATA_ROW, DATA_COL, etc, etc, goes to the shift registers... The board supports a rf, but it's not installed, so it's not the problem...

Actually, I don't even know why I put that capacitor there, but now i'd like to know what's happening

and hey... thanks for the reply... I wish we can solve that

On oscylloscope, i saw that the circuit stops working after the capacitor charges.

a 300uF cap directly across the power rails should charge pretty much instantly, right?

It almost sounds like you have the cap in between the AVR and one of the power rails. Except I calculate the time would still be very short...

At AREF, it's just decoupling capacitor as in the datasheet... Anyway, I am not using the AD...

Maybe it's not the charging that makes it stop... I thought that was the reason, cause when I saw it discharged, the circuit worked again... it doesn't work too long by the way

At AREF...

Sorry I didn't get my post removed in time. Please pretend you never saw it. :blush:

Surface mount part eh?

Are you sure the cap is connected to where you think it is? What does the cap charge up to when it stops working?
Once VCC is over ~3.9 volts, the processor should just run, and if it continues to 5V it should not make a difference.

If the power supply has enough current, the cap should charge up almost immediately if it is actually connected to VCC.

It charges pretty fast...

the atmega, the 100n caps and the shift registers are smd... the capacitor itself is pth

I'm starting to think that the behavior after I discharge the capacitor is just a coincidence, and it's charging is not actually the reason of the problem...

There appears to be a number of issues with your schematic/wiring. For starters I notice the following:

  • AREF should be pin 21
  • Avcc should be pin 20
  • Gnd should be 8 and 22

You better check them all and match the corrected schematic to your wiring.

The pinouts are correct for a 32-pin quad flat pack part.

CrossRoads is right... it smd part, so the pins are a bit different from the regular dip part...

Sorry - I didn't catch that.

Still it is difficult to explain this issue besides faulty wiring. Other than that I would check reset, power (including brown-out detection) and clock.

Stupid question, can you take the capacitor out of the circuit? Or change the program you're using to troubleshoot the problem?

If you're not sure if it's the capacitor or the software, changing one of them would be enough to determine that. Also, what's the voltage on the capacitor pins once it finishes charging?

Could the capacitor be defective?

I don't think the capacitor is defective, as I switched it and the problem wasn't solved...

bubulindo, I took the capacitor out of the circuit, and the problem never happened again. I'm just trying to understand what happend, so I don't make the same mistake again.

BenF, I also don't think that wiring problem. I soldered it, but it's a manucfatured board. Reset is right, and the brown-out detection is disabled. Also, I checked the 3v3 line after the system got stuck, and it's just fine... fixed at 3v3

So what is the capacitor voltage starting at and ending at?