Big Easy Driver Problem

Hallo zusammen
Ich habe meinen Schrittmotor über einen Big Easy Driver folgendermassen angesteuert.


Also so:
M+ : 24V
GND : GND Netzgerät
DIR : PIN 8
STEP : PIN9
GND : GND Arduino
Und den Motor mit den vier Kabeln an den Big Easy Driver wie auf dem Bild (ich weiss es ist ein Easy Driver auf dem Bild, aber die Anschlüsse sind gleich).
Nun meine Frage. Kann es sein, dass bei solch hohen Spannungen die Elektronik des Arduinos gestört wird? Also dass die beiden Stromkreise nicht sauber voneinander getrennt werden? Denn sobald ich die Stromversorgung anschalte, laufen die anderen Sachen in meinem Programm nicht mehr sauber. Bevor ich die Stromversorgung anschalte, läuft alles sauber. Oder kennt jemand eine andere Art den Big Easy Driver zu verkabeln?
Ich wäre sehr froh um jede Hilfe.

Eigentlich müßte es so funktionieren.

Erzähl uns mal welchen Motor Du hast und welchen Arduino.

Grüße Uwe

Ich benutze einen NEMA 17 Schrittmotor und den Arduino UNO aus dem Starter Kit.

michael03024:
Ich benutze einen NEMA 17 Schrittmotor und den Arduino UNO aus dem Starter Kit.

NEMA17 spezifiziert die Flanschgröße aber keine elektrischen Daten. Gegebenenfalls grob die Leistung da die mögliche Verlustleistung von der Größe abhängt.
Wir brauchen die elektrischen Größen des Motors.

Grüße Uwe

Ich weis, dein Bild ist nur eine Schema-Zeichnung, und dein tatsächlicher Aufbau kann ganz anders sein. Wenn er aber wirklich so aussieht, bist Du dann sicher, dass die unterste Reihe auf dem Breadboard komplett durchverbunden ist? Wir hatten das schonmal, dass diese Reihe in 2 Hälften organisiert ist, die man in der Mitte gegebenenfalls mit einem Draht überbrücken muss.
Wenn dem so wäre, hätte dein UNO keine Gnd-Verbindung zum Treiberbaustein, was durchaus allerhand 'Unsinn' auslösen könnte.

Ja, 2 solche Dinger hatte ich mir fälschlich auch mal zugelegt. Ich habe ne Weile gebraucht, bis ich das als Ursache gefunden habe. Die sehen ja bis auf die nicht durchgezogenen Linien aus, wie die anderen auch.

Gruß Tommy

Dus solltest auf jeden Fall die Sleep und Enable Pins noch entsprechend schalten. Wenn die nicht verbunden sind kann das auch zu komischem Verhalten führen.

Tarcontar