Big Sur Kernel panic

Hallo zusammen, seit ich den Update auf Big sur (OSX 11.2 ) gemacht habe, crashed mein Computer jeweils, sobald ich den Arduino uno über USB mit dem Computer verbinde und zeigt eine Kernel panic-Meldung.
Ich hab schon auf dem Netzt Recherche gemacht und auch einen neuen Treiber installiert GitHub - adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver: CH340G CH34G CH34X Mac OS X driver, aber es nützt nichts - jedesmal Absturtz sobald ich den Arduino mit dem Mac verbinde.

Draht:
... und zeigt eine Kernel panic-Meldung.

Öffne ein Terminalfenster und verfolge dort die Meldungen in /var/log/messages (?). Evtl. erscheinen dort hilfreiche Meldungen, wenn Du den Arduino anstöpselst.

Gruß

Gregor

PS: Der Befehl, den Du im Terminal-Fenster eingeben musst lautet

tail -f /var/log/messages

Die Eingabe zeigt mir folgendes: tail: /var/log/messages: No such file or directory

und zu welchem Zeitpunkt soll ich dies eingeben, denn der Computer stürtzt ja ab beim Einstöpsel. Ich kanns alo erst nach dem Neustart eingeben.

Draht:
und zu welchem Zeitpunkt soll ich dies eingeben, denn der Computer stürtzt ja ab beim Einstöpsel. Ich kanns alo erst nach dem Neustart eingeben.

Gib das nach einem Neustart ein. Dann stöpselst Du den Arduino und guckst, ob dabei bzw. vor dem Einfrieren des Systems Meldungen erscheinen. Bei mir sieht es unter Linux so aus:

Mar 19 13:48:50 mimi kernel: [ 3702.641074] usb 2-5: new full-speed USB device number 4 using xhci_hcd
Mar 19 13:48:51 mimi kernel: [ 3702.790080] usb 2-5: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.64
Mar 19 13:48:51 mimi kernel: [ 3702.790084] usb 2-5: New USB device strings: Mfr=0, Product=2, SerialNumber=0
Mar 19 13:48:51 mimi kernel: [ 3702.790087] usb 2-5: Product: USB Serial
Mar 19 13:48:51 mimi mtp-probe: checking bus 2, device 4: "/sys/devices/pci0000:00/0000:00:14.0/usb2/2-5"
Mar 19 13:48:51 mimi mtp-probe: bus: 2, device: 4 was not an MTP device
Mar 19 13:48:51 mimi kernel: [ 3702.814051] usbcore: registered new interface driver usbserial_generic
Mar 19 13:48:51 mimi kernel: [ 3702.814056] usbserial: USB Serial support registered for generic
Mar 19 13:48:51 mimi kernel: [ 3702.815825] usbcore: registered new interface driver ch341
Mar 19 13:48:51 mimi kernel: [ 3702.815831] usbserial: USB Serial support registered for ch341-uart
Mar 19 13:48:51 mimi kernel: [ 3702.815844] ch341 2-5:1.0: ch341-uart converter detected
Mar 19 13:48:51 mimi kernel: [ 3702.816128] usb 2-5: ch341-uart converter now attached to ttyUSB0
Mar 19 13:48:51 mimi mtp-probe: checking bus 2, device 4: "/sys/devices/pci0000:00/0000:00:14.0/usb2/2-5"
Mar 19 13:48:51 mimi mtp-probe: bus: 2, device: 4 was not an MTP device
Mar 19 13:48:55 mimi kernel: [ 3707.542244] usb 2-5: USB disconnect, device number 4
Mar 19 13:48:55 mimi kernel: [ 3707.542517] ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
Mar 19 13:48:55 mimi kernel: [ 3707.542543] ch341 2-5:1.0: device disconnected

Gruß

Gregor

PS: Du musst das als root („Systemverwalter“) tun. Um zu gucken, welche Dateien es in /var/log gibt, gibst Du folgendes ein:

ls -l /var/log

Du hast keinen Arduino sondern einen Arduino Nachbau. Kein Arduino hat den CH340 USB Adapter.

Ich schätze der Treiber für den CH340 ist (noch) nicht kompatibel mit OS 11.2
Auf der Herstellerseite ist der Treiber 3 jahre alt (Driver&Tools - Nanjing Qinheng Microelectronics Co., Ltd.)

Grüße Uwe

uwefed:
Du hast keinen Arduino sondern einen Arduino Nachbau. Kein Arduino hat den CH340 USB Adapter.

Ich schätze der Treiber für den CH340 ist (noch) nicht kompatibel mit OS 11.2
Auf der Herstellerseite ist der Treiber 3 jahre alt (Driver&Tools - Nanjing Qinheng Microelectronics Co., Ltd.)

Grüße Uwe

Das ist ungefähr das was ich auch vermute, auf Grund meiner Recherchen im Netz. Wahrscheinlich muss ich einfach noch warten bis es für Big sur einen Treiber gibt. Zum Glück habe ich auf meinem 2. Laptop noch ein älteres System und so werde ich bis dahin mit dem arbeiten. Danke für die Info!

gregorss:
Gib das nach einem Neustart ein. Dann stöpselst Du den Arduino und guckst, ob dabei bzw. vor dem Einfrieren des Systems Meldungen erscheinen. Bei mir sieht es unter Linux so aus:

Mar 19 13:48:50 mimi kernel: [ 3702.641074] usb 2-5: new full-speed USB device number 4 using xhci_hcd

Mar 19 13:48:51 mimi kernel: [ 3702.790080] usb 2-5: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.64
Mar 19 13:48:51 mimi kernel: [ 3702.790084] usb 2-5: New USB device strings: Mfr=0, Product=2, SerialNumber=0
Mar 19 13:48:51 mimi kernel: [ 3702.790087] usb 2-5: Product: USB Serial
Mar 19 13:48:51 mimi mtp-probe: checking bus 2, device 4: “/sys/devices/pci0000:00/0000:00:14.0/usb2/2-5”
Mar 19 13:48:51 mimi mtp-probe: bus: 2, device: 4 was not an MTP device
Mar 19 13:48:51 mimi kernel: [ 3702.814051] usbcore: registered new interface driver usbserial_generic
Mar 19 13:48:51 mimi kernel: [ 3702.814056] usbserial: USB Serial support registered for generic
Mar 19 13:48:51 mimi kernel: [ 3702.815825] usbcore: registered new interface driver ch341
Mar 19 13:48:51 mimi kernel: [ 3702.815831] usbserial: USB Serial support registered for ch341-uart
Mar 19 13:48:51 mimi kernel: [ 3702.815844] ch341 2-5:1.0: ch341-uart converter detected
Mar 19 13:48:51 mimi kernel: [ 3702.816128] usb 2-5: ch341-uart converter now attached to ttyUSB0
Mar 19 13:48:51 mimi mtp-probe: checking bus 2, device 4: “/sys/devices/pci0000:00/0000:00:14.0/usb2/2-5”
Mar 19 13:48:51 mimi mtp-probe: bus: 2, device: 4 was not an MTP device
Mar 19 13:48:55 mimi kernel: [ 3707.542244] usb 2-5: USB disconnect, device number 4
Mar 19 13:48:55 mimi kernel: [ 3707.542517] ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
Mar 19 13:48:55 mimi kernel: [ 3707.542543] ch341 2-5:1.0: device disconnected




Gruß

Gregor

PS: Du musst das als root („Systemverwalter“) tun. Um zu gucken, welche Dateien es in /var/log gibt, gibst Du folgendes ein:



ls -l /var/log

Scheint bei mir nicht zu funktionieren, aber ich hab den Fehlerbericht:

Ohne Titel.pdf (38.2 KB)

Draht:
Scheint bei mir nicht zu funktionieren, aber ich hab den Fehlerbericht ...

Das deutet stark auf das hin was Uwe schreibt.

Gruß

Gregor

gregorss:
Das deutet stark auf das hin was Uwe schreibt.

Gruß

Gregor

Ich glaub ich muss einfach etwas Gedult haben, bis ein neuer Treiber da ist. :confused:
Danke für die Hilfe!
Gruss Amédé

Schreib mal dem Hersteller.
Grüße Uwe

Das hatte ich auch mal gehabt aber nicht mit dem Big Sur.
Damals hatte ich andere Treiber genommen, probier das auch mal.

skorpi080:
Das hatte ich auch mal gehabt aber nicht mit dem Big Sur.
Damals hatte ich andere Treiber genommen, probier das auch mal.

Hab ich probiert, bin aber nicht weiter gekommen. Für Siera gibts schon neue Treiber, aber Big Sur ist wahrscheinlich noch zu neu. Ich hätte lieber noch etwas zugewartet mit dem Update!

uwefed:
Schreib mal dem Hersteller.
Grüße Uwe

uwefed:
Schreib mal dem Hersteller.
Grüße Uwe

Du meinst dem Hersteller des Arduino?

Was kannn Arduino wenn andere bei ähnlichen Platinen einen Ch340 verbauen und dessen Treiber mit Deinem neuen Betriebssystem nicht arbeitet?

Ich meine den Hersteller des CH340 der den Treiber bereitstellt oder eben nicht.

http://www.wch-ic.com/downloads/CH341SER_MAC_ZIP.html

Grüße Uwe

uwefed:
Was kannn Arduino wenn andere bei ähnlichen Platinen einen Ch340 verbauen und dessen Treiber mit Deinem neuen Betriebssystem nicht arbeitet?

Ich meine den Hersteller des CH340 der den Treiber bereitstellt oder eben nicht.

CH341SER_MAC.ZIP - Nanjing Qinheng Microelectronics Co., Ltd.

Grüße Uwe

Du hast recht. Und ich habs nicht mal bemerkt bei der Bestellung, dass das ein Klon ist!