Bluetooth as serial port trouble on Snow Leo


I've been trying to use a Roving Networks RN-41 and 42 modems to create serial connection between my Arduino and Max MSP/Pure Data. It used to work fine up until a few weeks. Now any time I try to connect the program (Max MSP, Pure Data or serial terminals such as Zterm and CoolTerm) freezes. I tried it on my old white Macbook and my wife MB with the same result. I reckon it must be something Snow Leopard specific problem, however I could not find any references to it (forum posts, for instance). The Bluetooth on my Macbook Pro works fine with my mobile and the Arduino works perfectly with USB. Any ideas would be appreciated!


Solved: go to HD/Developer/Applications/Bluetooth/Bluetooth Go to the Utilities and chose Modify Device and Software Configuration, tick all boxes and click on Perform. Apparently this erases the BT settings. After the reboot everything worked fine.

hey, im new in arduino...m jus tryin to send data using two similar bluetooth is it possible or not?