Bluetooth connection problem: COM Port busy

Dear All,

I am trying to setup a Bluetooth connection between my computer and an Arduino Mega and communicate via a Processing sketch.

At first the problem I am facing:
When the Processing sketch reaches the initialization of the Bluetooth connection, it shows the error message “Error opening serial port COM6: Port busy” (see attachment “Processing_PortBusy.jpg”).

And here is some information about my environment and he steps I performed:

  • Operating system: Windows 10
  • Sitecom Bluetooth dongle
  • I added the HC-06 as Bluetooth device and assigned a COM port. Now the HC-06 is listed in the Bluetooth properties (see attachment “Bluetooth properties.jpg”), and the COM port is also listed in the Devide Manager (see attachment “Device Manager.jpg”).
  • On the Arduino Mega, the HC-06 is connected to RX1 and TX1 as well as power.
  • The initialization in the Arduino sketch is done via “Serial1.begin(115200);”
  • The red LED of the HC-06 is flashing.

When I remote the HC-06 Bluetooth device from Windows and run the Processing sketch, he error message says “Port not found”, which is quite understandable.
But as soon as I add the HC-06 again, create a port for it, and run the Processing sketch, it says again “Port busy”.

I also tried to do some basic investigations with the “Echo Example” provided on this site: http://www.instructables.com/id/Add-bluetooth-to-your-Arduino-project-ArduinoHC-06/
I also tried it with an Arduino Uno, but got the same result.

But with this example I already fail when starting TeraTerm, because it says “Cannot open COM6”.

Since I am very new to the Arduino and Processing topics, I guess that I am doing one or even multiple very basic mistakes. But since I was not able to find a solution by just browing the Internet, I am asking you for some advice.

Thanks so much for any hint and best regards,
Markus

Processing_PortBusy.jpg

Device Manager.jpg