bluetooth service profile not found, linvor V1.8

a friendly hello :

bought 5 bt to serial modules from dx.com (SKU: 80711, $ 6.60)

tried to qualify them for a higher data rate on several pc's and an android tablet, before making changes to my software ... horrible experience so far :(

bt module radio (80711 from dx) connected to opto isolated ftdi usb to serial with 3.3 V dongle. 3.3v power for bt-module from opto dongle (defeats the opto, but 3.3 V) ... opto connected to kubuntu usb and opened in cutecom 9600 bd ... ATs all correct, no problem ... firmware version linvor V1.8 (new ???)

1a) xp32 guest in vmware 7.16 running on kubuntu natty host. bt-dongle with csr chipset on kubuntu host but switched through to xp32 guest xp32 installed bluesoleil bt app / drivers ... discovered bt-module by mac addr and name linvor ... paired ok ...

this 1st time i was able to connect after it announced the module as a serial device ... solid led light, connected xp32 communication with br@y terminal over bt to serial opto to usb to cutecom in kubuntu host works fine. cutecom string transfer "hello fred" worked twice on 20+ tries, but bt status window (bluesoleil) indicated ever string reception in the count field ... as said, br@y terminal displayed the strings only 2 times.

from hereon everything went downhill ... i decided to reassign the virtual com port number ... result ... was never able again to "connect" solid led light ... bluesoleil said can't find service

1b) uninstalled bluesoleil and finally got xp32 sp3 bt-stack working ... module pairs ... once it indicated that it found a serial device and provided a com port number, but 5 mins later com port number gone ... didn't find the spp service or whatever the serial service / profile is called ... pairing ok ... but NO connect anymore

2) tried on a win 7 schlepptop (built in bt radio, ms-bt-stack) with similar indications as indicated in 1b.

3) tried on another schlepptop with external usb bt-radio and bluesoleil ... results as 1b.

4) tried on a samsung tablet (android) ... pairing ok ... no service found, therefor no connect

note all of these bt-tries worked fine with a belkin headset audio device (b21)

did anyone using a similar device within our arduino family experience similar problems or is it perhaps new with the linvor V1.8 slave firmware ... or am i doing something wrong ... i'm developing hardware and writing firmware for 30 years ... just don't know what could be wrong.

schematics for the 3.3 V opto usb 2 serial dongle can be found at http://wiki.efihacks.com/index.php?title=EfiMini_Opto-Coupled_3.3_V_Serial

i just don't know what could be wrong with the dx.com Wireless Bluetooth V2.0 RS232 TTL Transceiver Module for $ 6.60

i also ordered 3 save and 2 master devices from

http://www.electrodragon.com/?product=30ft-3-3vdc-wireless-bluetooth-rf-transceiver-module-rs232-ttl

but they have not arrived yet ... so i can't compare

please please, any help is highly appreciated

cheers, blue2u

well meanwhile we discovered some of the shortcomings or misleading aspects of this really cool and inexpensive bt module ... a bit misunderstood at the very beginning

the key to success is to powercycle the bt module in case of any difficulty ... but 1st unpair the module so that the bt os is not connected to it anymore

one more time ... unpair the module ... turn off the power to it and turn it on again ... pair one more time and everything from there on should be working ...

we did a 3 part series of walking through all of these steps on our blog with illustrating the individual steps as good as we could

in case of the links not working goto efiHacks.com and select news to get to the blogs ... also over time these links might change ... the efiHacks,com site is not too likely to fade away :)

here they are ... using bluetooth serial port experiences part 1 http://www.efihacks.com/144/ using bluetooth serial port experiences part 2 http://www.efihacks.com/223/ using bluetooth serial port experiences part 3 http://www.efihacks.com/using-bluetooth-experiences-part-3/

i hope it helps ... we can go through it now blindfolded

one more thing to consider is binary data transfer over a bluetooth slave device

we also have answers for it as the last paragraph of this page http://wiki.efihacks.com/index.php?title=EfiMini_Binary_Data_Xfer

this will effect the embedded arduino developer using a bluetooth slave device using binary data

enjoy ... it took us several days of hard work to come to these conclusions ... the efihacks engineering team

p.s we're very happy with the modules so far :) more stress testing is needed ... what a week

I am using same fw version.

First I'd like to upgrade some older versions using 1.5V to 1.8V. Do you know how I can do it?

Second, I'd like to add a feature to HC-06 linvorV1.8, which is manual baud select based on button. Where to get source for this fw? Available?

Thx