BME280 connection rings seem to be very different from BMP180 connection rings

After more than a few hours, was not successful in getting first BME280 from Adafruit to be seen by sketch. Received the standard error "..... check wiring. Since I soldered stacking header onto BME280, I assumed I was the problem and trashed the BME280.

I purchased a second BME280 but did not solder the stacking header. I had same problem. I used i2cdetect and was able to see the addresses for BMP180 and AM2513 and get them working with the arduino provided test sketches (i2c). Went back to BME280 and saw same error. I decided to play with the unsoldered stacking head by moving it around while running i2cdetect. When holding stacking head at an acute angle, i2cdect saw the BME280 address. I soldered one end of the stacking head, retried i2cdetect but had no success. I then soldered wires directly to BME280. This solved my problem. I2cdetect saw the address. BME280test worked.

Can anyone explain why I had this connection problem with BME280 and not BMP180?

Kevin

Well, obviously the second BME 280 wasn't working because of poor contact being it wasn't soldered, can't say about the first unless you can retrieve it from the landfill. Think about the unsoldered one, there are 4 pin holes, two of the pins may be hard against the inside of their holes, 1 pin hard against the outside, the fourth pin may be centered in it's hole and not making contact at all.