Board arduino_due_x_dbg (..) is unknown Error compiling.

hello to everyone!

i had a lookup in the net to find answers to this problem but i didn't solve it yet.

i'm trying to compile my arduino code (like really ANY code , for example also i tried with the AnalogReadSerial provided on the arduino ide examples) on my arduino DUE but the ide plots me errors like:

Warning: platform.txt from core 'Arduino AVR Boards' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}". Consider upgrading this core.
Board arduino_due_x_dbg (platform sam, package arduino) is unknown

Error compiling.

i can't understand the meaning of this, so i hope maybe one of you can direct me to the solution.

to be noted: i've already:

  • unistall the pakege on the tools/boards/boards manager changing versions
  • unistalled and installed the entire arduino ide
  • i have checked the serial monitor and is responding properly (i have still my code runnig on the arduino so i can say it fro shure)ù
  • i tested the ide compiler with another board the arduino uno, and is comiling properly the code
  • i foud out that the compiler runs on my arduino due only if i define the board as a Yun :o :o

any idea??

cheers,
Francesco

Here's the GitHub issue for your problem: 1.6.6 no longer works with third-party boards/libraries · Issue #4137 · arduino/Arduino · GitHub There is a workaround mentioned there but they seem to have gotten sidetracked on a different issue and closed it without ever finding the actual cause of this error

Hi!
Can somebody fix the error?
Arduino IDE 1.6.7 SAM 1.6.5 (I have tried SAM 1.6.2, 1.6.3 and 1.6.4)
I have the same:

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware
"C:\Program Files (x86)\Arduino\hardware" -hardware
"C:\Users\Daniel\AppData\Local\Arduino15\packages" -tools
"C:\Program Files (x86)\Arduino\tools-builder" -tools
"C:\Program Files (x86)\Arduino\hardware\tools\avr" -tools
"C:\Users\Daniel\AppData\Local\Arduino15\packages" -built-in-libraries
"C:\Program Files (x86)\Arduino\libraries" -libraries
"C:\Users\Daniel\Dropbox\Public\ArduinoSketch\libraries" -fqbn=arduino:sam:arduino_due_x_dbg -ide-version=10607 -build-path
"C:\Users\Daniel\AppData\Local\Temp\buildf4c58e6d04bb7704deff2edd96a1bfb7.tmp" -warnings=all -prefs=build.warn_data_percentage=75 -verbose
"C:\Users\Daniel\AppData\Local\Temp\untitled1981650387.tmp\sketch_dec23a\sketch_dec23a.ino"

Board arduino_due_x_dbg (platform sam, package arduino) is unknown

Error compiling.

Using Arduino IDE 1.6.5, and SAM 1.6.4, I don't have errors

Solved!
I entered on Boards Manager...and Arduino SAM Boards version 1.6.5 was the latest version showed for me.
So I clicked on "Remove" and BINGO the version 1.6.6 appeared and the compile worked fine.

Yes, deleting some old versions solved my problem too!