Board from arduino.org not compatible with IDE from arduino.cc

Hello,

I ordered some arduino Uno boards from Amazon and they happen to have come as arduino.org boards. Interestingly enough, the messaging on the box asked the user to download a new IDE from arduino.org.

I have always been a supporter of arduino.cc and have always used the IDE from arduino.cc, but I was unable to upload the blink sketch to the boards that came from arduino.org. I kept on getting the error below whenever I tried to upload the sketch.

avrdude: stk500_recv(): programmer is not responding

In order to fix the problem, I had to reflash the bootloader on the arduino, and ever since then the uno’s have been working fine.

So I was wondering if anyone else experience this as it looks like arduino.org might intentionally be making the bootloader on their boards incompatible with the arduino.cc IDE…

I hadn't heard of any such thing. What ide version do you have?
There was briefly arduino.cc code that printed an obnoxious and noisy warning about .org boards, but still worked.
Did you select the correct serial port? It might. Be different on a .org board...

I was supplied with two .org Nano's and had no problems with the .cc IDE.

Weedpharma