Board manager report and running IDE do not match.

I have been using IDE 1.6.6. nightly build on Due and it correctly identifies as such in main window title bar.

Just tried Board manager and it reports 1.6.4. INSTALLED for Due.

There are no other options reported by Board Manager to install for Due.

1.6.4 is the version of the Arduino SAM Boards package that you have installed. There is no problem with the version numbers being different.

pert:
1.6.4 is the version of the Arduino SAM Boards package that you have installed. There is no problem with the version numbers being different.

Huh...
I am running 1.6.6. and have installed 1.6.4. ??

Please explain what is "package" then.

Thanks

1.6.6 is the version of the Arduino IDE you're using. There are various boards packages(hardware cores) that you can install using Boards Manager to add support for different boards. These packages contain the boards.txt, platform.txt, core libraries, tools, etc for a set of boards. For example Arduino AVR Boards, Arduino SAM Boards, Arduino SAMD Boards, Intel Curie, esp8266, etc. Each of these packages has a version number also. They are two different software entities so the versions don't need to match. If you look at the Arduino AVR Boards package you have installed it's probably something like 1.6.9. The IDE version and the boards package version numbers don't have any relation to each other, they are just a way of identifying the version.

Thanks for very clear explanation.
Case closed.