Board not detected for esp8266

I am getting an error upon upload but I am not sure why. The hardware works on my older laptop with the same setup. I have tried different usb ports. I have tried different version of esp8266 board. Nothing seems to work.

  • upload speed: 115200
  • Board: Generic esp8266 board, tried multiple version including the latest.
    Nothing I can find online is working so I am not sure why it wont recognize that the board is connected.

Here is the error...

esptool.py v3.0
Serial port COM4
Connecting...
Traceback (most recent call last):
  File "C:\Users\justi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\3.0.0/tools/upload.py", line 66, in <module>
    esptool.main(cmdline)
  File "C:/Users/justi/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.0/tools/esptool\esptool.py", line 3552, in main
    esp.connect(args.before, args.connect_attempts)
  File "C:/Users/justi/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.0/tools/esptool\esptool.py", line 519, in connect
    last_error = self._connect_attempt(mode=mode, esp32r0_delay=False)
  File "C:/Users/justi/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.0/tools/esptool\esptool.py", line 499, in _connect_attempt
    self.sync()
  File "C:/Users/justi/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.0/tools/esptool\esptool.py", line 438, in sync
    timeout=SYNC_TIMEOUT)
  File "C:/Users/justi/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.0/tools/esptool\esptool.py", line 376, in command
    self.write(pkt)
  File "C:/Users/justi/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.0/tools/esptool\esptool.py", line 339, in write
    self._port.write(buf)
  File "C:/Users/justi/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.0/tools/pyserial\serial\serialwin32.py", line 325, in write
    raise SerialTimeoutException('Write timeout')
serial.serialutil.SerialTimeoutException: Write timeout
the selected serial port serial.serialutil.SerialTimeoutException: Write timeout
 does not exist or your board is not connected

What part of this is confusing?
Have you verified the port is present using the device manager?

It is confusing because the port is recognized by device manager. Also, the hardware works on my other laptop. So why is arduino saying it can't recognize it.

Which ESP board?

I had the same problem couple days ago.

The problem are the driver. When you download the zip folder with your arduino ide, there is a folder inside named: "drivers". I just ran dpinst-amd64.exe there and it starts working.

So strange because I used the installer and not the zip, which doesn't have this driver in it. In any case, this fixed the issue but I am getting another bug associated with esptool. Now it says this...

esptool.FatalError: Failed to write to target RAM (result was 0107)

It is ESP8266.

Ok, I switched usb cables and it seems to be fine now. I tried this earlier with no success but I think you showed me a resolution to my originial issue. This was a secondary issue. Thanks!

I had the same strange thing with this driver. I've worked with esp and everything was fine, I didnt even needed the driver, but after I moved my pc to another room, it stops working, so I had to use the installation. dunno how is that possible

That is the chip on the board. Which board? Wemos D1 Mini, ESP8266-01, NodeMCU?

It is the wemos d1 mini