Boards have disappeared

Yesterday I finally got my wemos d1 mini working and today when I opened the arduino ide my board was set to arduino yun and approx 10 boards have disappeared! Almost like someone is having a laugh.

How can this be? I had a few esp8266 boards showing in the list, but now all gone.

Pls help

Please verify that the URL of the ESP8266 JSON file is still present at File > Preferences > Additional Boards Manager URLs.


I had a similar issue the other day. Saw some other post about. Can't find that other post at the moment. But since then. The ESP8266, Wemos D-1 mini boards show up and then disappear. Currently, they are showing up. 20 minutes ago they were not. Kind of confused on what's happening. I apologize if you've answered this like a million times before. Here's what's in my board preferences.
Using IDE version: 1.8.4


I think it has something to do with the Arduino IDE not being able to access the URL. The IDE downloads that JSON file to check whether a new version is available for installation. If something goes wrong and the local copy of the JSON file is lost then the boards disappear. The correct behavior would be for the IDE to not erase the local copy until the remote copy has been successfully downloaded. I remember looking into this a while back and not being able to reproduce the problem.

Here's what's in my board preferences.

You shouldn't use that ESP8266 URL. You won't be able to update to new versions. The latest release of ESP8266 core for Arduino is 2.4.2 but you're still on the outdated 2.4.0. This is the correct one:

Ah! Thank you sir.

Hi Guys
I am having the exact same issue ( again)!
Board manager worked fine, then all my boards and libraries disappeared! Except for the default ones.
I have tried a fresh install several times to no avail.
I have downloaded the Git Hub Esp 8266 core 2.4.2 version,
modified the Preferences as shown but always get the same message;
"package_index.json file signature verification failed." again and again.
I'm at a loss. I even disable the Windows 10 driver signature verification app to no avail.
Can anyone point me in the right direction.
I mean everything was working , then overnight GONE!! like someone took an eraser to my computer.

Thanks in advance for any help.

Try this:

  • Click the link at the line following File > Preferences > More preferences can be edited directly in the file. This will open the Arduino15 (or similar name) folder.
  • Delete all files except preferences.txt. Please be very careful when deleting things on your computer. When in doubt back up!
  • Tools > Board > Boards Manager

Hopefully this time you will not encounter the verification failure.

I even disable the Windows 10 driver signature verification app to no avail.

Windows driver signature verification has nothing to do with this error.

Thank you for taking the time to try and help. Reviewing dozens of posts on this forum , I see that you seem to be knowledgeable on theses topics.

However, even with a fresh install of Arduino 1.8.6, and following your instructions to the letter, my case is still unresolved.
It did however, stop the original error " package_index.json file signature verification failed."
The Board Mgr loaded up lots of Boards but no esp8266's
I now get the error"error downloading".

Is there a way to download the file and insert it into a new or predetermined file in the Arduino directory hierarchy?
Or perhaps you know of another way.
Seems I'm doing more troubleshooting than coding or making.
One of the posts suggested Platform io.
I have no desire to start learning a new system but getting frustrated.

Once again Thanks for your input.

I now get the error"error downloading".

Is that the exact error. If so, that indicates you don't have the correct URL in your File > Preferences > Additional Boards Manager URLs. It should be:

Seems I'm doing more troubleshooting than coding or making.
One of the posts suggested Platform io.
I have no desire to start learning a new system but getting frustrated.

PlatformIO is best for people who want more advanced features than the Arduino IDE provides and don't mind a more complex interface. I feel that the Arduino IDE is the best option for beginners. Some of these advanced features have intentionally been left off of the Arduino IDE because the priority is for it to be very accessible to anyone, rather than having a steep learning curve. This lack of features can be frustrating for advanced users and for them it's great that there are some alternatives to the Arduino IDE. I think you'll end up dealing with a lot more problems rather than less if you switch to PlatformIO, though I'm sure once you get it figured out you'll be happy.

I appreciate your taking the time to help me out. I have always liked the Arduino IDE and have spent many hours enjoying coding and seeing the results take action.
What bothers me is why the boards dissapeared in the first place.
It's unsettling to think that after many hours of work, one day, for some unknown reason ( at least to me)
that it might just vanish.
Anyway, I'm back up and running, thanks to you, and will not abandon Arduino quite just yet.
However during my frustration , I did download Platform IO for Atom and will give it a look.

Thanks again.

Any chance anti-virus "real time scanning" is in play here? Some of them, especially McAfee and Trend Micro, cause a lot of problems for Arduino.

I have read about this on different places aswell on this forum.
I would like to mention that I too have similar effects from my ide and board manager. What I have noticed is when I disconnect from the internet but still work via my wifi router thereafter not only does the 8266 boards disappear but also any other boards that was loaded via the manager for example the attiny 25/45/85 boards. I can work for days without any problems if I stay away from the router. It would appear board manager tries to check for updates and being unable to connect via the internet then aborts and those files disappear. With the next connection to internet the files are restored. But without a refresh from the internet all added boards are unavailable. This operation does not seem to happen when working iso ie not with router connected. Does board manager only check for updates when it sees a connection to the internet? It is rather anoying when I would want to test a connection to a 8266 via the router just to find that next boot or board change only to find the bear ide available without the added installed boards via the manager. I have more than one board in the prefered list.


I have read all the above and this seems a good place to ask the question

I loaded the ESP board files and all was working fine, but then I diverted to load the BBC microbit board for the grandson, and now I have lost the ESP boards from the list of boards.

I realise now that in Files | Preferences, the 'Additional Boards Manager URLs' is a list and I should have added microbit to the list of boards. But I just pasted it in the box (over the ESP entry).

Random Nerd suggests that to recover, I should delete the ESP Espressif folder, and reload in the normal way. He says this folder is in the Arduino 'hardware' folder , but the instructions he gives do not locate the 'hardware' folder for me.

Can someone please help me find the espressif folder or suggest another way to reinstall ESP?

  • just putting the ESP link in Additional Boards Manager URL doesn't install them

Many thanks!

Do this:

  • File > Preferences
  • In the "Additional Boards Manager URLs" field, add both the microbit URL and the ESP8266 URL, separated by a comma.
  • Click "OK"
  • Tools > Board > Boards Manager
  • Wait for downloads to finish.
  • Click "Close".
  • After that, you should now see both the microbit boards and the ESP8266 boards on the Tools > Board menu.

Thanks for that speedy response pert, but how weird!

I am actually using ESP32, but just putting that on its own in the 'Additional Boards manager' field did not restore ESP32, but doing ESP32 + microbit does!

Nodoubt someone can explain why?

I am actually using ESP32

OK, the topic was originally about ESP8266 and you only said "ESP Boards", but it makes no difference.

just putting that on its own in the 'Additional Boards manager' field did not restore ESP32, but doing ESP32 + microbit does!

By "that" do you mean the ESP32 Boards Manager URL? Did you open Boards Manager after adding the URL? That step is essential. Just adding the URL only won't make the boards show up.

You might be right. In my haste to get my ESP boards back I didn't read my notes of how I had done it before. Loading new boards is something I have only done twice in my three years of using Arduino.

Anyway. All is working now. Thanks for your help.

You're welcome. I'm glad to hear it's working now. Enjoy!

New issue with boards not showing up on a laptop.
I have two PC’s,
-a desktop running Linux Mint 19.1 & Arduino 1.8.9 both were upgraded to latest versions and compiling ESP8266 & ESP32 works fine before & after updates.

  • a laptop that I re-installed LM19.1 & Arduino 1.8.8 and the basic Arduino IDE works fine, but, when I installed ES8266 & ESP32 cores, they do NOT show up in the Board list!
    The board manager shows that they installed correctly and the files are located in home/xxx/.arduino15 directory.
    Comparing the desktop & laptop files & locations, they are identical.

I have read the forum and there seems to have been some issues about where these files located including in home/Arduino/hardware.
My desktop does have a hardware folder with a ArduinoTMS32 core (but no ESP cores), but the laptop has no such folder.

For the hell of it, I added a Tiny core to both systems and predictably the correct files were generated and placed in the same directories, in a packaging & staging folder, the boards do show up on the desktop but again DO NOT show up on the laptop!

Is this an issue with Arduino IDE 1.8.9 ?
Where should the cores ultimately finish up ?

I need the laptop for doing OTA updates. I will try earlier IDE’s, but I believe the earlier versions had problems with OTA update!

I just tried 1.8.5 and it appears to behave the same.
I also installed Arduino under /opt but it behaves the same.
I have been trying to resolves this for a few weeks now & have done a lot of seaching for ideas.

So, I am stumped at this time! Looking for further ideas!