Boards maganer Error

Have a problem ever since I tried to load the board file for the nRF52832. When I go to Board manager is doesnt want to update. Get the follow error- Error downloading

Any one have an idea what this is and how to fix it please

It probably has nothing to do with the custom Boards Manager URL you added to preferences for the nRF52832 hardware package. Boards Manager always tries to download the official .json file ( first before any additional URLs and if the first download fails it just gives up and doesn't even try any others.

Usually this is caused by network security settings that are preventing the Arduino IDE from accessing the internet. You need to whitelist the Arduino IDE in your firewall software.

Can you load in the browser on the computer that's having the problem?

yes i am able to open that in a browser

That just confirms that your browser can open the file but you still need to investigate whether your network security settings are preventing the Arduino IDE from accessing it.

Dont know if that would have change. I did manage at on stage to get the board in the boards manager but then the example program did not want to complile. I uninstalled Arduino IDE and installed the latest version. But after that the Boards manager start giving problems. Where can I check the network settings for Arduino

Maybe the new installation was not whitelisted. You need to make sure that specific installation of the Arduino IDE is allowed to access the internet in your firewall software.

I added it to the list of allowed programs in the firewall setting and selected both Private and Public. I added it to my anti-virus software. But still the same problem persist :confused:

Try this:

  • Click the link at the line following File > Preferences > More preferences can be edited directly in the file. This will open a folder named something like Arduino15.
  • Delete all files in that folder except for preferences.txt. Please be very careful when deleting files on your computer. When in doubt, back up!
  • Try Boards Manager again.

It's possible that a download of the Boards Manager file was corrupted and that file is blocking you from downloading it again. The file is downloaded to the Arduino15 (or similar name) folder so by deleting it you clear out any corrupted files.

There we go. Who's the BOSS, Pert is
Thank you very much