Bool Loader

on pressing the reset button on my Arduino Duemilanove board(ATmega 328), the led on pin number 13 doesn't blink as it should as mentioned in the Arduino troubleshooting indicating that there is some conflict with the Boot Loader.. Please let me know how can i burn the bool loader back into the Arduino.. thank u!

There are other reasons the LED would not blink (voltage regulator damaged; processor damaged; bad USB cable; LED damaged).

Have you performed any tests other than reset-does-not-blink?

no i haven't.. but i have checked it with a number of USB cables, same problem.. and regarding damaged led, i have 8 arduino duemilanove boards with the same problem.. so i don't suppose that the led has been damaged..

regarding other tests, i have no idea.. please make me familiar with the tests.. ty!

Did the boards ever work?

Do you have a functioning board or an ISP?

i do not have an ISP, but yeah can arrange for a working board…

can’t we burn the bootloader using a Parallel Programmer…???

Do you mean something like this?
http://www.arduino.cc/en/Hacking/ParallelProgrammer

Did the boards ever work?

yeah yeah i meant that only…

and yeah of course all the boards worked the best they can… my robotics experiments might have damaged them…

I suggest running a loop-back test on the board. If that test fails, there is no point in re-burning the bootloader.

http://arduino.cc/forum/index.php/topic,73748.0.html

Unless you have a Parallel Programmer that you know works, I suggest avoiding it. If you can get your hands on a working board, use these instructions for re-burning the bootloader...

http://arduino.cc/en/Tutorial/ArduinoISP

...with one additional step...

1.5 Disable auto-reset. Instructions are available here...

http://www.arduino.cc/playground/Main/DisablingAutoResetOnSerialConnection

Finally, spycatcher2k graciously offers a repair service...

http://arduino.cc/forum/index.php/topic,68577.0.html

cb, hello.. i tried burning the bootloader using an AVRISP mkII but this din't work out.. the loop back test u suggested worked successfully with my boards..

trying to burn the boot loader using AVRISP mkII generated the following instantly.. avrdude: usbdev_open(): did not find any USB device "usb"

please assist!

aakash

i tried burning the bootloader

Using the Arduino IDE? Or using AVRDUDE from the command line?

Using the Arduino IDE.. tools>burn bootloader > avrisp mkII..